Remote Desktop does not connect

I have been trying to setup Remote Desktop Access, to no avail.
Both the Host and Server are running Windows 7 Pro 64bit.

I set up the Host Computer to allow Remote Desktop Access, see Attached Screen Shots RemoteDesktop1 and RemoteDesktop2.
I set the Host Firewall, see RemoteDesktop3.
In the Host's Router I forwarded port 3389 to the Host's static IP, see RemoteDesktop4. (Per Microsoft's instructions).

When I tried to access the Host remotely I got the Error Message in Attached Screen Shot RemoteAccess5.
I even tried to include Port 3389, see Attached RemoteAccess6.

Thanks,

Biggles1
Can anyone tell me what I was doing wrong?
RemoteDesktop1.JPG
RemoteDesktop2.JPG
RemoteDesktop3.JPG
RemoteDesktop4.JPG
RemoteDesktop5.JPG
RemoteDesktop6.JPG
Biggles1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
If RDP is enabled and you still have the firewall enabled but trying to allow specific ports or services, try disabling the firewall completely. This will be a good test to see if you have configured the ports on the firewall successfully.

If you have any other 3rd party firewalls on your machine you might also want to disable them as well.

Will.
RantCanSr. Systems AdministratorCommented:
It works internally correct? so you can rule out the windows firewall, or an ACL or somesuch.

Also, you should pull down the photos that show your IP address and obscure it prior to reposting said photos.
NVITEnd-user supportCommented:
If you've isolated the port per Will's comment ID: 40894234, check the port used at registry key "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp\PortNumber"
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Biggles1Author Commented:
How do I remove and the re-upload Screen Shots?
Wayne88Commented:
Can you tell us more about the remote location? Is it possible that the remote router/firewall is blocking port 3389?
Angel6677Commented:
Are both computers running on the same network? Or are you trying to run it from outside the network?
If it's the second one, are you using a vpn connection??
Biggles1Author Commented:
Here are the answers to some of your postings:
Will Szymkowski: If RDP is enabled and you still have the firewall enabled but trying to allow specific ports or services, try disabling the firewall completely. This will be a good test to see if you have configured the ports on the firewall successfully.  I did disable the Host PC's Firewall

If you have any other 3rd party firewalls on your machine you might also want to disable them as well.
and I also Un Installed the Antivirus completely. Same results.

How do I determine if RDP is enabled?  I would imagine that allowing Remote Desktop, it would be automatically enabled.

RantCan:  It works internally correct? so you can rule out the windows firewall, or an ACL or somesuch.
What is ACL?

Wayne88:   Can you tell us more about the remote location? Is it possible that the remote router/firewall is blocking port 3389?
I tried with turning off the Firewall on my own (remote) PC.  On my Router, which is a Netgear WNDR4000, how would I make sure that Port 3389 is not blocked?
David Johnson, CD, MVPOwnerCommented:
you have to forward port 3389 from the wan to the ip of the computer you want to control.
A complete walk through is available @ http://portforward.com/english/routers/port_forwarding/Netgear/WNDR4000/Remote_Desktop.htm
Biggles1Author Commented:
David Johnson, MVP

I did forward port 3389.  See attached screen shot RemoteDesktop4.jpg.

My question is, why does Microsoft recommend Port 3389?  Could I use another Port?
Wayne88Commented:
"My question is, why does Microsoft recommend Port 3389?  Could I use another Port?"

That's the standard RDP port.  Yes you can change it, follow this instruction


"I tried with turning off the Firewall on my own (remote) PC.  On my Router, which is a Netgear WNDR4000, how would I make sure that Port 3389 is not blocked?"

I don't think you can scan the packet with this router but chances are you should be find.  Is the host IP static?  If it's dynamic there is a chance it may have changed.
RantCanSr. Systems AdministratorCommented:
Biggles1Author Commented:
It just occurred to me that the way I set up Remote Access does not designate the Host Computer I want to access remotely.  This Host is not the only one on the LAN.  So how would I "tell" Remote Access to connect me to another Computer?
David Johnson, CD, MVPOwnerCommented:
use different ports for different computers

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Wayne88Commented:
Agree.  Give your computer a specific port number that's not being used by other RDP then port forward from the router to your computer.

Here is an additional instruction on how to change the port on your computer:

How to: Configure a Network for Multiple Remote Desktop Connections
Biggles1Author Commented:
Hi Guys,

Sorry for the three day silence but I have tried EVERYTHING, and nothing seems to work.  I need to contact the ISP and ask them to open port 3389.

In the meantime I used www.canyouseeme.org and could not find a single port that is open!

Is that normal?  Can anyone tell me which port should be open just for the purpose of testing?

Thanks again for all the responses.
Biggles1Author Commented:
Problem solved.  Thanks for all your help.  If you are interested in what the problem was, here it is:

The Router was in a "Double Nat" configuration.  IE the Internet was first routed by a Comcast router which supplied a 10.1.10.XXX subnet to ANOTHER router that supplied a 192.168.XXX.XXX subnet to the LAN computers. Why? Because the first router also feeds a set of Security Cameras (10.1.10.XXX).

I resolved the problem by removing the second Router.  Now the LAN has a 10.1.10.XXX subnet! AND the PC's can now (with a software interface supplied by the Camera Supplier) "see" the Cameras!  This has made the customer very happy!

Note to self:  KNOW YOUR NETWORK!  Comments appreciated.

Regards and thanks again.

Biggles1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.