Wordpress Won't Install Because Of HTTPS

Hi,

I am trying to install Wordpress into a folder / directory on my website, which is hosted by Digital Ocean (droplet).

Considering Digital Oceans accounts are self managed VPSs i am not getting much luck with help from their support, which is understandable.

The main parent website (custom php) is working fine, however when i try to install the Wordpress into the /blog directory i get to the installation page, it seems that none of the wordpress assets (css, js, etc...) are loading, because the installation is trying to run on http instead of https.

screenshot
As you can see none of the assets are loading, so the same applies when you land on the blog home page AFTER you complete the installation steps...

Also, it is important to point out that i can't install any plugins to help, because if i try go to the admin login after the installation, i get looped back to the installation page because of the https issue.

Can anyone offer any advice, thanks in advance for your help.
oo7mlAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
Are you sure it's an ssl/https issue? Are the directory/files permissions set correctly?
The permissions should be set to following:
For Directories:
find /path/to/your/wordpress/install/ -type d -exec chmod 755 {} \;

Open in new window


For Files:
find /path/to/your/wordpress/install/ -type f -exec chmod 644 {} \;

Open in new window


Another thing to try, if it's an https issue, is to set following in your wp_config file:
define('FORCE_SSL_ADMIN', true);
define('FORCE_SSL_LOGIN', true); 

Open in new window


Paste that in the wp_config file right before the text that tells you to stop editing...
0
Ray PaseurCommented:
This is not a solution, just an explanation of what _might_ be happening.  When you set cookies in PHP, the setcookie() function observes a "Secure" parameter.  If this is set, the cookie will only be sent to HTTPS connections.  And the browsers will only return those cookies over HTTPS connections.  HTTP cookies are not affected - they will be set and returned over HTTP or HTTPS.  So if WP sets some of its required cookies with "Secure" and some without "Secure" the non-Secure cookies would not come back to anything other than HTTPS connections.  This might not be readily apparent if the connection was AJAX, because the URL might not be visible.
http://www.w3.org/Protocols/rfc2109/rfc2109
0
rgranlundCommented:
Make sure the correct info is set in the config.php file.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.