Server 2012 Remote Desktop Deployment Botched

I did a less than brilliant thing and was working on a Remote Desktop setup to replace our old Terminal Services setup for the handful of users that remote in after I had everything else configured on this server.

In my effort to get it to behave like the old Terminal Services where external users would use the RD client to connect and only be able to see the apps I published (and I never did get this to work through a client, only the web interface), I tried using User Profile Disks. When I realized I had it messed up, I removed the Remote Desktop feature and that's when the trouble began.

Now, every time I login to this server as any user, including my admin account, it gives me the message "Please wait for the Remote Desktop Configuration" and then ends up sending me to a temporary profile.

I would like to get the server back to logging into my regular admin profile (which still exists in the Users folder), but I can't seem to make that happen. Any suggestions are appreciated and if you need more details, please ask.
ericl143Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NinjaStyle82Systems AdministratorCommented:
You re-added the feature again after removing it?
0
ericl143Author Commented:
No, the feature is removed, but the problem I described remains as if something didn't uninstall correctly.
0
NinjaStyle82Systems AdministratorCommented:
have you rebooted yet?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

ericl143Author Commented:
Yes, several times including making sure the removal task was complete after the 1st automated reboot.
0
NinjaStyle82Systems AdministratorCommented:
Are the old disks still showing up?
0
ericl143Author Commented:
Yes, I did try deleting them, but they are recreated with each login. I have removed all of the ones created manually, but the one in the picture is the one created for my admin login I have been using to try and figure this out.User Disks screenshot
0
NinjaStyle82Systems AdministratorCommented:
if you log in as a different user does it also create a new profile disk, or just from your admin account?
0
NinjaStyle82Systems AdministratorCommented:
sorry to clarify, a user who does not already have a profile
0
NinjaStyle82Systems AdministratorCommented:
also, if you run the following powershell command does it give an error or does it actually work?

Get-RDSessionCollection
0
ericl143Author Commented:
It appears to create a temporary disk as in the picture above, but for each user I sign in with, creates a folder another temp folder in the "Users" folder as shown here.
"Users" folder screenshot
0
ericl143Author Commented:
As for the Powershell command, it errors out with:

Windows PowerShell
Copyright (C) 2014 Microsoft Corporation. All rights reserved.

PS C:\Users\TEMP.CPCPRINTS> Get-RDSessionCollection
Get-RDSessionCollection : A Remote Desktop Services deployment does not exist on cpc-apps15.cpcprints.com. This
operation can be performed after creating a deployment. For information about creating a deployment, run "Get-Help
New-RDVirtualDesktopDeployment" or "Get-Help New-RDSessionDeployment".
At line:1 char:1
+ Get-RDSessionCollection
+ ~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Get-RDSessionCollection

PS C:\Users\TEMP.CPCPRINTS>
0
NinjaStyle82Systems AdministratorCommented:
This is a weird one, I think maybe try re-enabling the RDS feature, and see if it will let you disable the UPD piece with powershell.

Set-RDSessionCollectionConfiguration [-CollectionName] <string> -DisableUserProfileDisk
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ericl143Author Commented:
That worked. I still have a problem now that my administrator account is still using a temporary profile, but at least the whole remote desktop issue is gone.
0
NinjaStyle82Systems AdministratorCommented:
awesome. Maybe if you backup the profile, then delete it from a different admin account, you will get a fresh non-temp profile you can restore the original to?

https://support.microsoft.com/en-us/kb/2462308
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.