Hyperlinks with hardware IP address work, but identical link with loopback IP does not

We have been using a tool called ePublisher by WebWorks to build help documentation which then gets installed on a process control system for context sensitive help.  We used to use local machine IP addresses in our hyperlinks to the context sensitive help application, but we changed to using the loopback IP a couple of years ago so that the code in our application is IP independent.   This has worked wonderfully for us for quite a while.

2 example Hyperlinks, one in the old style (hardware IP) and one in the new style (loopback IP):
Successful:
http://192.168.1.1/ProductHelp/_en/Index.html?context=Product1&topic=ScreenName1
Successful:
http://127.0.0.1/ProductHelp/_en/Index.html?context=Product1&topic=ScreenName1

We recently added a new screen to our product, and have subsequently built some help documentation for that screen, but when we add the equivalent Hyperlink to that application, the link doesn't work:
Unsuccessful:
http://127.0.0.1/ProductHelp/_en/Index.html?context=Product1&topic=ScreenName2

First we confirmed that the loopback IP resolves properly (no reason it shouldn't, but just in case)
Successful:
http://127.0.0.1/ProductHelp/_en/Index.html?context=Product1&topic=ScreenName1

Then we checked that we have the proper hooks in the WebHelp application for the hyperlink by replacing the loopback IP with the hardware IP again:
Successful:
http://192.168.1.1/ProductHelp/_en/Index.html?context=Product1&topic=ScreenName2

I haven't the slightest clue where to check next to figure out what would be different between using the hardware IP vs the loopback IP in hyperlink that would cause it to fail, especially since the hardware vs loopback IP both work when pointing to a different page.
LVL 1
TomProAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ste5anSenior DeveloperCommented:
What error do you get in the browser? What error messages do you find in the web servers log?

Is your web server case sensitive? May be a typo?

How does your web server handle those parameters? Wrong url rewriting, wrong routing?
0
strungCommented:
Anything in your hosts file  that might be causing the problem?
0
TomProAuthor Commented:
Ste5an / strung - We were testing, and we tried with a half dozen other users logged into the same machine and some of those were successful, and some not.  The ones that were successful are not regular users of that machine, so we thought maybe user profile had something to do with it.

1) Deleted user profile
2) Recreated user profile
3) Retested -> Success

Not sure what about that process has anything to do with user profile, but it's the solution I needed.

Sorry for wasting people's time, I'll close the question, and throw some points to both of you for trying to help.
Much appreciated.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TomProAuthor Commented:
There was obviously just a profile conflict that caused problems, so it's not really a solution that explains why the problem appeared in the first place, but the solution is simple enough.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.