Dell R610 Perc 6/i No Boot Device Available

Hello,

I have a PowerEdge 610 with a Perc 6/i that is booting up to the error "No boot device available" after a power outage.  When the server boots, it loads the controller and sees the Virtual Disk 0 and it initializes 100% then posts that error.  I have checked the RAID controller and it reports no errors, all discs are online and the Virtual Disk is in Optimal condition.  Virtual Disk 0 is set in the controller as a Bootable Disk. I pulled a drive just to make sure the controller was actually reporting correct data and it recognized the removal and then started to rebuild the drive when I put it back in.

THere are 4 drives in the server in a RAID 10 array.  On it we are running ESXi with a couple Windows hosts.

Any thoughts?

Mike
LVL 1
ClearBlueTechnologiesAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PowerEdgeTechIT ConsultantCommented:
Check the boot sequence to make sure HDD/PERC is enabled (checkmark). You might also check into running a repair of ESX startup.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
The master boot record of the ESXi installation is corrupted.
ClearBlueTechnologiesAuthor Commented:
What is the best way to repair it?
SolarWinds® IP Control Bundle (IPCB)

Combines SolarWinds IP Address Manager and User Device Tracker to help detect IP conflicts, quickly identify affected systems, and help your team take near instantaneous action. Help improve visibility and enhance reliability with SolarWinds IP Control Bundle.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Re-install ESXi.
rindiCommented:
Just as a suggestion, why don't you install ESXi to a USB stick or SD-Card? I don't know about your server, but many models have an internal card reader and USB port so you can use internal SD-Cards or USB sticks to boot to ESXi. You then don't need to mix ESXi with your datastores on the HD's. You can make a copy of such a stick which is quickly replaced if one goes bad. You will just have to change the boot order of the server to boot from the stick or SD-Card instead of the RAID controller.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ClearBlueTechnologiesAuthor Commented:
Kind of weird.  I put a 5.5 install disc in and tried to boot to that and it returns the same error...even after changing the boot sequence.  I will try to put ESXi 5.5 on a USB and try that but find it odd that it won't boot to a DVD that I have confirmed is burned correctly in another machine.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Make sure the ISO you have used has the words visor in it, e.g. installation media.
ClearBlueTechnologiesAuthor Commented:
So I got it installed on a stick and booted the server to it but cannot see the datastores or the respective VMs. Is there something that I am missing to see the existing storage (which was internal)?
rindiCommented:
Did you install the Dell branded version of ESXi? That will normally be more compatible and include the proper drivers and management agents.
ClearBlueTechnologiesAuthor Commented:
No, didn't know there was a difference or how to get it.  It shows the Dell disk in the Devices list and shows it is mounted.  Will 5.5 see previous versions?  I'm not 100% sure of what version the host had.  I don't think it was 5.5 but was hoping 5.5 would see it.
rindiCommented:
It should be available via the Dell download site.
PowerEdgeTechIT ConsultantCommented:
ClearBlueTechnologiesAuthor Commented:
Thanks all for your help.  I ended up having success with the Dell version of ESXi.  Then I had to re-add the Datastore as it didn't find any persistent ones.  I did that by creating a new datastore but using the existing information.  It scanned and found the old information.  Then I had to re-add the VMs to the host inventory...then update the VMWare tools on the VMs.  So far so good and have it running from the USB stick.  Thanks again!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.