Wordpress on Ubuntu

I am installing wordpress on Ubuntu.

The only command that has not successfully completed is

sudo chown -R demo:www-data *

chown: invalid user 'demo:www-data' - error message

When I visit localhost I get the "It works" page. When I visit http://localhost/?p=1 I get the same page (it works).

https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-on-ubuntu-14-04
burnedfacelessAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hieloCommented:
For this guide, we will use the same account that we set up during the initial server setup guide (https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-14-04), which we called demo. This is the account I am performing all of the actions of this guide as.

The group ownership we will give to our web server process, which is www-data. This will allow Apache to interact with the content as necessary.

We can quickly assign these ownership values by typing:

sudo chown -R demo:www-data *
https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-on-ubuntu-14-04

The initial setup link shows you how they created a user account named "demo" (follow the link above).  So, you need to add a user named "demo" and a group named "www-data".  Refer to the Command Line section at:
https://help.ubuntu.com/community/AddUsersHowto
1
DrDamnitCommented:
I'm assuming you've installed Apache using apt-get. But, what you didn't tell us is what is the DOCUMENT_ROOT directive set to. By default it's /var/www/.

Please check /etc/apache2/sites-enabled/ and tell me what's in there. Most likely, you've just got a 000-default (or similar).

Open that file, and look for the document root.

Your Wordpress installation needs to be in there.

Next, confirm that you did (indeed) install Wordpress there. If your directory structure is /var/www/wordpress/ then, that's part of your problem, you need to go to http://localhost/wordpress/ instead of just http://localhost/

You also need to know what user apache is running as. Execute this command and copy / paste the output:

ps aux | grep -i apache

Your chown command probably failed beause Ubuntu doesn't have a "demo" user by default on the system. You're probably running as root or as www-data (for both he user and group, so chown -R www-data:www-data would probably work).

Give me that feedback, and I'll help you further it along after I see some data.
1
burnedfacelessAuthor Commented:
The file is blank.

When I run the command I get "No such file or directory".
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

burnedfacelessAuthor Commented:
I am also reading up on demo user, thanks.
0
hieloCommented:
>> "No such file or directory"
Try running:
$ /usr/sbin/apache2 -V | grep SERVER_CONFIG_FILE

the result should tell you the path of the main config file, which should have the DOCUMENT_ROOT setting.
0
burnedfacelessAuthor Commented:
I am still getting "No such file or directory".
0
hieloCommented:
Are you sure there is no /etc/apache2/apache2.conf file?
http://www.ducea.com/2006/06/11/apache-tips-tricks-default-apache2-configuration-files-location/
https://help.ubuntu.com/lts/serverguide/httpd.html

Also, did you get a chance to add the 'demo' user and the 'www-data' group?
0
burnedfacelessAuthor Commented:
I have glanced through the tutorials and I am trying to learn wordpress to upload to an external server.

With linux I must be the server (i.e. Digital Ocean subscription)? Am I understanding this correctly? As in it must run on a public server in Ubuntu?

Sorry for the newb questions.
0
DrDamnitCommented:
Is this aa digital ocean server our somewhere else?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
burnedfacelessAuthor Commented:
It was somewhere else. I don't need to configure my own server for now so I will not use digital AA server.

I was able to get it running off of Apache which was my initial goal to start writing html and use Ubuntu to start learning php security because I do absolutely none.
0
DrDamnitCommented:
You need to learn apache and Linux security before you try to do php security. If you dint know the OS add the web server platform, your efforts at PHP security will be in vain.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
WordPress

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.