Invalid TLV record

I have a POS (CounterPoint SQL) that uses Crystal Reports for its reports. I have the app installed on server 2008 r2. When trying to open a report and/or print I get an invalid tlv record error. But, here is why I ask this question...

It does not happen for one account which is a domain admin and admin on the machine. It happens on everyone else. I myself am a domain admin and I get the error if I log in as myself. I don't get it if I log in with the domain admin account that I use for server logins.

All of the CR folders/files on the system have everyone permission. The app folder has everyone permissions. The machine and default registry keys have everyone permission for both as well.

How do I determine what is different between these two logins that is keeping this from working.

On a side note, I have this same setup on a 2003 server and do not have the problem.
JenniferIT DirectorAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vastoCommented:
I have seen this message when a Crystal reports file version 9 or above is opened with older version of Crystal reports designer or runtime( for example Crystal Designer 8.5)

Which version of Crystal are you using?
Is it possible that the newer Crystal Runtime is installed on a drive not available to some users ?
mlmccCommented:
That is a fairly generic error message.

One common cause is a report is corrupted but since it is by user rather than all the time, the rpt file is most likely ok.

Crystal uses virtual directories for the temp files required to build the report
The name and path changes with the version.  That is so different versions of Crystal can be installed on the same machine.  You need to ensure everybody has permissions to use them (write/modify)

This link tells you where they are by version
http://scn.sap.com/community/crystal-reports-for-visual-studio/blog/2011/07/07/why-succeeding-versions-of-crystal-reports-net-web-applications-work-on-same-web-server

mlmcc
David Johnson, CD, MVPOwnerCommented:
What can cause that error message and how to fix it @ http://knowledgebase.progress.com/articles/Article/000032003
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

mlmccCommented:
I doubt very much it is missing files since some users can run.  It is more likely permissions either on the virtual directories or perhaps on some of the run time files (that would make them appear to be missing)

What version of Crystal are you running?

Have you contacted the developers of the POS application?
Perhaps it is not fully compatible with Server 2008

mlmcc
JenniferIT DirectorAuthor Commented:
vasto, I have made sure there are no other runtimes installed.
David, I have seen this article, in fact these instructions are in multiples all over the web, all done and not the problem

mlmcc, agree, this can be a generic error message. Since the program and/or report works fine for some and not others I have to agree that the necessary files, the reports, etc. are fine.
I do not have CR installed on the machine. It is not needed. The POS installs everything necessary to allow the app to run the reports. The application itself is installed on a 2008 server. The 2003 server is a terminal server, which is what this 2008 server is going to be. It works fine on both of those. Unfortunately I didn't set either of those up so I don't know if anything special was done. The company that supports the POS charges $150/hr for support and they are not very helpful. Their forum and knowledgebase are useless when it comes to most things but especially this type of problem.

You made a good note though, one thing I forgot about was the temp files. I believe I already checked the virtual directories but I will check both of these and see if that may be the problem.
JenniferIT DirectorAuthor Commented:
I have checked every file and folder related to both the app and CR. All of them have 'everyone' FULL access rights. I can't find where it is creating the temp files but I have given permissions to Windows Temp anyway.

I did a system repair using windows upgrade. The server seems fine. Since I did that any users were re-created with new profiles (I wiped out anything that was there previous).

So the account it works with, call it admin, works fine. I log in either on the machine itself or I remote in and run the app, call it CP, and I am able to pull up and/or print any report.

I login as myself (reminder I am a domain admin as well) and it will not pull and/or print a report. I did finally find a way to get it to give me a message when it fails. It isn't really an error but instead an event log. I have posted below.

I decided to give myself local admin rights to the machine as well. Logged off, logged back in, opened CP, tried to pull a report, no. Didn't work.

It is almost like the only user that it works with is the one that was used to install CP. Like for some reason giving everyone full permission isn't taking affect. Any other suggestions?

2015/08/03 13:08:58>> Creating form
2015/08/03 13:08:58<< Creating form
2015/08/03 13:08:58****************************************
2015/08/03 13:08:58***** Changing reports
2015/08/03 13:08:58***** Old report: (None)
2015/08/03 13:08:58***** New report: Admission1_rpt
2015/08/03 13:08:58****************************************
2015/08/03 13:08:58>> Loading report
2015/08/03 13:08:58   >> Creating Crystal application
2015/08/03 13:08:58      Crystal version = 10.0
2015/08/03 13:08:58      Runtime path = C:\Program Files (x86)\Common Files\Crystal Decisions\2.5\bin\craxdrt.dll
2015/08/03 13:08:58      Craxdrt dll version = 10.0.5.1258
2015/08/03 13:08:58      Viewer path = C:\Program Files (x86)\Common Files\Crystal Decisions\2.5\crystalreportviewers10\ActiveXControls\crviewer.dll
2015/08/03 13:08:58      Viewer dll version = 10.0.5.1155
2015/08/03 13:08:58   << Creating Crystal application
2015/08/03 13:08:58   >> Loading report from disk
2015/08/03 13:08:58      Filename: \\Operations\cpsql.1\TopLevel\System\PSForms\Admission1.rpt
mlmccCommented:
Is this a application you wrote (your company) or is it a third-party application?

Did the reports come with the application?

Is this a new report (recently created)?

DO you create reports in Crystal?
If so have you updated Crystal?  That error sometimes appears when the Crystal used to create the reports is at a different (usually higher) service pack level than the dlls used for the application.

What version of IE is installed?
Does the user have permissions to use ActiveX controls?

mlmcc
JenniferIT DirectorAuthor Commented:
It is a third party application, CounterPoint SQL.
Yes the reports came with the application.
No, it doesn't pull any reports at all.
I do but not on this server nor for this report I am trying to pull. This is a new server install, no crystal reports installed except for what the app installs for it.
IE is 11, the app doesn't use a browser though.
Yes, I am a domain admin and gave myself local admin rights. It works if I log in with a different domain/local admin account but not for anyone else.
mlmccCommented:
Try setting IE to compatibility mode.  There are some parts of IE that the viewer uses.  I know when I initially installed CR 4.6 it also installed the current version of IE at that time.  

Check ActiveX rights for non admin users.
I think it may be trying to install the viewer activex control

mlmcc
JenniferIT DirectorAuthor Commented:
mlmcc, it has nothing to do with compatibility mode. This application does not use any web. Besides it works on other machines with compatibility and without. It is CR 9, which itself is old but CR 4.6 is very old. As I said in previous post I have already checked all permissions. It does the same thing for me and I am an admin. It only works for the one user which it was installed by.
JenniferIT DirectorAuthor Commented:
I have instead decided to wipe the machine and start over.

Sorry but no one really got but multiple people tried to help so I am grading on that alone.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JenniferIT DirectorAuthor Commented:
I am grading on the fact that it isn't fixed but there was offers of help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.