Can't access application after power surge

We had bad weather recently which resulted in a power surge for most desktop computers. We use a POS called CounterPoint SQL. It is installed locally with the ini pointing to the server. After the power surge I have one user who can no longer access the app. If you click to run it you just get the start screen then it just sits and spins. It never comes up.
I have uninstalled and reinstalled the software.
I have uninstalled and reinstalled the security software (this was suggested by the forum for CounterPoint).
I have tried to do a system restore.

Still nothing. Right now I have accessing the app through RDP but I need him to access it locally again.
Any thoughts on what else to do to get the app connected again without having to do a complete redo?
JenniferIT DirectorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott CSenior EngineerCommented:
You've done everything I would have done before finally getting to the wipe and reinstall stage.

I assume by system restore you mean you rolled back to a restore point.

If that didn't do it, then I'd redo the system.  You don't know what other apps might have been affected.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
Power surges can do significant damage to the operating system which appears to have happened here.

You can try System File Checker to see if that gets you running. Open cmd.exe with Run as Administrator and run SFC /SCANNOW twice. Shut down, start up and test.

A deeper repair is Windows 7 Repair Install. You need the matching Windows 7 DVD, boot from it and select the Repair option. DO back up first. Here is a Seven Forums tutorial to assist you.

http://www.sevenforums.com/tutorials/3413-repair-install.html
0
jcimarronCommented:
Jennifer--
And in the future you should have all the PC's (and server) protected by a surge protector or combination Surge Protector and Uninterrupted Power Supply.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Scott CSenior EngineerCommented:
Amen to that.  A couple of days ago we lost power.  I very calmly went around to each machine in our house and powered them off.
0
nobusCommented:
maybe running a disk check can help here
0
JenniferIT DirectorAuthor Commented:
John and nobus, thanks I will give system file check a go, I had not done this yet since this app seems to be the only thing affected. At least as far as I can tell so thinking about it there could be other problem, file check and/or repair is a good idea.

jcimarron, having worked in this field for a very long time surge protectors and UPS are not new to me. Every server including a couple key PC's are on an UPS. Every other PC in the company including other electronic equipment is on a surge protector. Maybe you have never had one of those fail but unfortunately it does happen.
0
nobusCommented:
also - test the motherboard as well as possible; it may have been hit also
here a nice video test : http://www.passmark.com/download/index.htm
0
JohnBusiness Consultant (Owner)Commented:
It must have been a big surge. I had a surge kill a consumer router but not the computers or printers. Anytime I have a UPS in place, equipment is protected.
0
JenniferIT DirectorAuthor Commented:
I have some very old used equipment here so 1 machine out of 45 with a  problem is not bad just wish I could figure out what the problem is. I don't like just redoing them instead of figuring it out but in this case I can't spend any more time on it.

Either way, none of the suggestions have worked, I tried all of the above and many others. Thanks for the suggestions.

Fortunately I have an image so I am just going to swap out with a new machine then re-image this one.
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and good luck with your equipment.
1
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.