Suppressing a prompt to update a linked workbook upon opening

I have a macro that requires opening a specified workbook which is linked to other workbooks and I always get a prompt asking whether or not I want to update. How do I prevent that from happening?  "Application.DisplayAlerts = False" doesn't do it.

Thanks,
John
LVL 1
John CarneyReliability Business Tools Analyst IIAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Open Excel, Options, Advanced and down near the bottom, uncheck Update Links to Other Documents.
Roy CoxGroup Finance ManagerCommented:
You need to set the Updatelinks property, something like this added to you code

Dim sFil as String
sFil= "C:\YourFile\PathHere\YourFileName.xlsx"
 Workbooks.Open Filename:=sFil, UpdateLinks:=0

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Saurabh Singh TeotiaCommented:
John,

If you don't want to go to the route which John Hurst suggested..In your macro you can just add this line which is...

Application.AskToUpdateLinks = False

Open in new window


This will take care of you getting that alert when you open a workbook which has external links..

Saurabh...
John CarneyReliability Business Tools Analyst IIAuthor Commented:
Thank you all for your answers. Roy's works the best because it also suppresses the 'Some links can't be updated ...' alert which comes up after the first alert.

John, if i understand tour answer it's only going to work for me not for others who don't have the update option checked.

Thanks,
John
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Excel

From novice to tech pro — start learning today.