CANON MP 470 returns ‘Unsupported Colorspace’ with OS 10.9

MARSPATH
MARSPATH used Ask the Experts™
on
CANON MP 470 returns ‘Unsupported Colorspace’ with OS 10.9

Drivers (3) for CANON MP470PIXMA from page below,when installed return printer error ’Unsupported Colorspace’  The correct OS version (10.9) is detected.

http://www.usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mp_series/pixma_mp470#DriversAndSoftware

Suggestions from Web re: System Preferences…Printers & Scanners do not refer to current OS 10.9 setup.

e.g. “Canon MP470 and OS 10.9 drivers return Unsupported Colorspace”

How do I get this printer (and scanner) to work with OS 10.9?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Go the the link you provide and manually select your OS and Language to download and install the correct drivers.
http://www.usa.canon.com/cusa/support/consumer/printers_multifunction/pixma_mp_series/pixma_mp470#DriversAndSoftware

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial