strange compiler behavior

I have a large Delphi application with many units
From time to time I "build" it so all units are recompiled.
But today doing that, one unit has many DCC errors that are "false" errors : I mean these are not error at all, it just look likes the compiler becomes crazy !
Looking at dates, I see that the unit source is dated june 3, 2015 and the dcu is dated june 12, 2015
That date (12 june) is the last build I did and I did not get any errors (dcu was created).
Since then the source was not changed (3 june last update)
So I am completed stucked with that and I even can not modify the source because if I update it, Delphi will have to recompile and will fail (I tried, same crazy errors)
The incorrect errors are of many types, incompatible tyes, undeclared identifier, etc
Please help !
LVL 1
LeTayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lopemCommented:
What version of delphi are you using? Have you tried to compile unit by unit to see if any of them are causing the strange problem? A really strange problem

regards
Manuel Lopez (Lopem)
0
LeTayAuthor Commented:
Delphi XE2
How can I compile just one unit ?
0
LeTayAuthor Commented:
I created a separated project and included the "guilty" unit
It failed exactly with the same crazy errors, and no other ones, when it should have reported many other errors due to the fact that the unit was "isolated" from all (needed) others.
Is it possible that the source is corrupted one way or another ?
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

lopemCommented:
Can you share your sample project and "guilty" unit to check it here?
0
LeTayAuthor Commented:
Can do that but very very large
In fact, I found a work around !
The first error occurs on a record definition
That one is defined in another referenced  unit...
I just copied the definition on the "guilty" unit and compilation was ok
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lopemCommented:
So problem solved! Great!

regards
Lopem (Manuel Lopez)
0
LeTayAuthor Commented:
Is it possible to close this
No real solution
0
Geert GOracle dbaCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: LeTay (https:#a40899233)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

Geert_Gruwez
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Delphi

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.