P2P Sql Server Express and Windows 8.1 Connection Problem

andrewl77
andrewl77 used Ask the Experts™
on
Hi,

I have recently been forced to get two new pc's both running windows 8.1 (don't/didn't have time to roll back to windows 7) that replaced two windows 7 pc's that have gone to the land of pc's that no longer work.

I have sucessfully reinstalled all the software to both however I have an application that uses sql express servers with windows authentication that is now not working on the pc that connects remotely.

TITLE: Connect to Server
------------------------------

Cannot connect to taskbay1\sqlexpress.

------------------------------
ADDITIONAL INFORMATION:

Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. (Microsoft SQL Server, Error: 18452)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&EvtSrc=MSSQLServer&EvtID=18452&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

How can i change PC2 to be trusted on PC1 so that the PC2 can connect to the databases?

They have both joined the same homegroup and all other settings are identical to my previous windows 7 setup that worked without fault.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
SQL Expert/Infrastructure Architect
Commented:
Create the EXACTLY same account on both PC's
I e, the same local account with identical names AND identical passwords.

Then use this account to Query SQL from the machine without SQL.

Ofcourse you need to assign permisstions to this account on the SQL Express instance.

Regards Marten
HuaMin ChenProblem resolver

Commented:
Try to put this
	<connectionStrings>
		<add name="conn2" connectionString="Data Source=192.?.?.?\your_db_instance;Initial Catalog=your_db_schema;Integrated Security=False;User ID=your_db_login;Password=??????" providerName="System.Data.SqlClient"/>
	</connectionStrings>

Open in new window

within Web.config/app.config file in your project, to ensure the project will work fine with the database.
David ToddSenior Database Administrator

Commented:
Hi,

On the 'server', have you checked that network access is configured?

HTH
  David
Marten RuneSQL Expert/Infrastructure Architect

Commented:
Andrewl77

Have you tried any of our suggestions?
Please give us feedback, so we know if the issue us solved or if more assistance is needed.

Author

Commented:
Yes.  ended up having to change both PC's to the same name and use the same login details for both PC's to get the remote pc to open the SQL database.  Not ideal but its working atleast.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial