Email delivery challenge

Hello, I am running an Exchange 2010 messaging environment. For some months, I have been experiencing email delivery failures to some email addresses/domains.

I get messages like :

honolulu.directrouter.com rejected you message to the following email addresses:
honolulu.directrouter.com gave the error: no such user here
box607.bluehost.com rejected your message to the following email addresses: xxxxxx@domain.com
em12345I.servername.com rejected your message to the following email address: yyyyy@domain.com
em12345l.servername gave this error: please turn on SMTP authentication in your mail client or login to the IMAP/POP3 server before sending your message.
server58.web-hosting.com rejected your message to the following email address: zzzzzzz@domain.com. server58.web-hosting.com gave this error: No such person at this address.

For all the messages, if you try sending the same message in about 5 minutes, the message goes through.

Has anyone experienced this ?
chux75Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Marshal HubsEmail ConsultantCommented:
You should try Microsoft Exchange Troubleshooting Assistant to determine the cause of performance, mail flow https://www.microsoft.com/en-us/download/details.aspx?id=25213 .

For more info, you can visit http://blogs.technet.com/b/sbs/archive/2008/01/03/what-to-check-when-exchange-cannot-send-email-to-certain-domains.aspx
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chux75Author Commented:
The recommendation pointed me to the solution.
I resolved all DNS related issues and setup mail flow monitoring from MXToolbox.

All seem to be working well now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.