HP DL380 G6 CPU Upgrade to X5670's - Wont Boot

I am trying to upgrade my DL380 G6 from E5520's to X5670's, but upon doing so, the server does not boot. I get no image on my screen, no post-messages, etc. Infact, I get no VGA signal at all.  The fans spin up, then spin back down, and nothing.

Things I have tried:
Verified BIOS is 2013.07.02
NVRAM reset (switch S6)
Changed BIOS setting  Minimum Processor Idle Power State to C1E state
Changed BIOS setting Intel QPI Link Power Management option to "Disabled"
Tried reducing RAM to just 1 RDIMM per channel

FYI, the sSPEC for the old E5520's are SLBFD's and the new X5670's are SLBV7's. But I don't think this should matter anyway?

I am at a complete loss. I had the exact same issue trying to upgrade a different server a couple months ago to 5600 series, and I ended up just resorting back to 5500's.

The memory I have installed is 18 x 4GB PC3-10600 Dual-Rank ECC (500658-B21) (again, I did try reducing this to 1 RDIMM per channel to no avail)
LVL 1
jroozeeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PowerEdgeTechIT ConsultantCommented:
The quick specs from HP state that 5500-series processors are supported but don't say anything about 5600-series. Do you have some reason to think they should work?

http://www.hp.com/products1/servers/carrier_grade/dl380_cg/specifications.html
http://www8.hp.com/h20195/v2/GetPDF.aspx/c04282582.pdf?ver=24
0
jroozeeAuthor Commented:
I was going off of this: http://www8.hp.com/h20195/v2/GetPDF.aspx/c04282582.pdf  Which does say it supports the X5600 series up to and including the X5670
0
jroozeeAuthor Commented:
I noticed the URL for my PDF is identical to yours except yours is specifying version 24 of the document.  So it appears HP added support for the 5600 series processor -- but is that simply based on the latest BIOS?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

Chris HInfrastructure ManagerCommented:
http://h20565.www2.hp.com/hpsc/doc/public/display?sp4ts.oid=3884313&docId=emr_na-c03898078&docLocale=en_US

This guy is saying BIOS before 7/1/2013, so I'm wondering if the 7/2/2013 update removed the X56xx support.

http://serverfault.com/questions/620872/hp-proliant-dl380-g6-with-2-x-intel-x5650-cpus

Any fans missing?

Read last answer  "Clear BIOS"

Try pulling BIOS battery..
0
PowerEdgeTechIT ConsultantCommented:
Well, the available date of the 5670 is Q1 2010, so it would have no doubt been added to the 2011 BIOS version (approximately the date of the document you referenced) and only enhanced in the 2013 and 2015 versions. Before back-flashing to 2011 though, I'd try flashing to the 2015 version, as it is unlikely the support would have been removed, but if there was an issue with the 2013 version, it may have been corrected in the 2015 version.
0
jroozeeAuthor Commented:
Based on the release notes of the 2015 bios, i dont see any reason it would make a difference. However i will try it when i am able to take the server off line again.

(PS) am i able to use all 3 channels of memory with the X5670 on this server? The quickspecs makes a note about using only up to 2 channels with 5600?
0
PowerEdgeTechIT ConsultantCommented:
Based on the release notes of the 2015 bios, i dont see any reason it would make a difference. However i will try it when i am able to take the server off line again.
I agree, but undocumented BIOS changes/fixes happen all the time.

Intel says the processor supports 3 channels, and I don't see anything in the user guide for that server that would limit the number of CHANNELS (although quad-rank DIMM's would limit the number of DIMM's per channel), so I'm not sure what the limitation is there, but unless the 2013 or 2015 addressed that limitation I would probably plan on that being the case. Did you try a single DIMM in only one (or two) channels?
0
Chris HInfrastructure ManagerCommented:
Have you tried clearing the bios by yanking the battery and power?
0
jroozeeAuthor Commented:
No but it is my understanding that the s6 switch is effectively the same thing?
0
Chris HInfrastructure ManagerCommented:
Do it.  Rule it out.  That will kill the time, so make sure to set it in the BIOS before the OS loads, especially if it's a VM host or DC
0
jroozeeAuthor Commented:
I am unable to download the 2015 Bios because it requires entitlement. I donot have a HP support contract. Any other way i can get it?
0
PowerEdgeTechIT ConsultantCommented:
You have to have support for the latest system updates?!?!
0
andyalderCommented:
Yes, they learnt that anti-competitive trick off Oracle. There is a 2014 DVD at http://www.driversguru.com/driverdetail/2131041-Smart+Update+Firmware+DVD (disguised as a printer driver which it is not). Release notes for BIOS say 5600 support introduced Version:2010.03.30 (14 Apr 2010)  though.
0
jroozeeAuthor Commented:
So since we're pretty certain it's not the BIOS, any other ideas other than doing a hard-clear of the BIOS settings?
0
Chris HInfrastructure ManagerCommented:
I've had a lot of weirdness associated with video, memory and processor upgrades.  I honestly think it has nothing to do with the allocated "BIOS", but memory banks used to store configuration and bootcode provided by the mainstream manufacturer as opposed to the hardware manufacturer.  I've found the only way to clear it is to yank the battery, pull the power, hold down the power button for complete drain.  Come on, I can't be the only expert who's had to do this on more than one occasion.  

Just three days ago, I swapped video cards (PCI to PCI-e) and doubled the memory in a stadium scoreboard server, couldn't get video, same exact symptoms you have, tried EVERYTHING.   Finally, I pulled the battery and power.  Wallah..

I'm not saying this is going to fix it, but if you have physical access to the server (which I'm assuming you do since you're upgrading processors), why not rule this out.
0
PowerEdgeTechIT ConsultantCommented:
Sure, occasionally, but clearing the NVRAM using the jumpers has always been sufficient.
0
jroozeeAuthor Commented:
Now that I think about it, I don't think the S6 jumper reset the NVRAM. Because after trying that, I remember that all of the original BIOS settings I had set were still in place.  So I think that the bootup process didn't even get to that point to clear the NVRAM.

I will try the hard method of removing the battery and also will try doing a "Reset to Defaults" in the BIOS.  Wont be able to try this until tomorrow.
0
andyalderCommented:
You have to power it on after switching switch 6, then it gives a message about CMOS being reset to defaults and tells you to turn it off and switch switch 6 again. The effect is slightly different than pulling the battery out since it deliberately resets default values rather than just corrupting CMOS.

Damn switch bank is so small I can hardly see it and have to use a pin to switch it with. In the old days when they used the Dallas RTC chip with integrated battery "cat /dev/random > /dev/cmos" could wreck motherboards ;)
0
jroozeeAuthor Commented:
i know you have to power it on. but i wasnt getting any VGA signal even still. so i dont think it processed the NvRAM reset.
0
Chris HInfrastructure ManagerCommented:
Yanking the battery has ALWAYS worked for me.  Every CMOS is designed to take a power loss.  Hence the battery.  That stuff is tried and true.
0
andyalderCommented:
I'd be tempted to remove the CPUs and take photos of the sockets (that's partly because of my failing eyesight though).
0
jroozeeAuthor Commented:
Why?
0
Chris HInfrastructure ManagerCommented:
Any follow-up?
0
jroozeeAuthor Commented:
I wont be able to get to it until this Friday or Saturday. Will keep you posted.
0
jroozeeAuthor Commented:
So I tried doing:

BIOS Reset to Factory Defaults
Removed CMOS Battery for 5+ minutes and held power button in to clear NVRAM
Reduced to just 1 DIMMM
Tried each X5670 individually in socket #1

Nothing worked. Infact, while the X5670's were in, the mother board instantly starts beeping when it powers on.

The exact part # of the CPU's is 587493-B21
0
jroozeeAuthor Commented:
I think I just found the problem!

I ordered these: http://www.serversupply.com/PROCESSORS/Intel%20Xeon%20Six-Core/2.93GHz%20-%206.4GT%20QPI/HP/587493-B21.htm

But upon looking at the CPU's more closely, I realized they actually shipped me X5687's!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jroozeeAuthor Commented:
I cant believe i never checked the CPUs. I assumed what I received is was what I ordered.
0
jroozeeAuthor Commented:
Just to Confirm. I installed the CORRECT CPU's today and the problem has been resolved. I can't believe I didn't double check the CPU Model #'s
0
jroozeeAuthor Commented:
Turns out the model #'s of the CPU's were wrong and I was the only one to think of double checking that
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.