Error Access OWA for certain users on Microsoft Exchange 2007 WSS

We've just migrated our WAN from a two external IP system using VPN's across two states, to a single external IP with multiple subnets on a WAN over . Our head office has an AD and Exchange server of and has OWA working externally.

Our other office on another subnet has a mirrored AD and Exchange server of They used to have a completely separate public IP address and URL to access their OWA and all was good.

Now we have only 1 public IP address, I want any user to be able to connect to the OWA no matter where their mail server is physically located. However when a user tries to connect they get this error.

Error message from OWA for people on SA server.
I've removed the External URL from the remote server, but still nothing works. I've restarted IIS multiple times too and the servers appear to have the same settings as they are mirrored settings.

These are my settings from the two servers.

Western Australia
WA server settings
South Australia
SA server settings

What am I missing?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Amit KumarCommented:
You can do it with CAS proxying.

In this case you don't have to map both Exchange servers with Public IP always. your one exchange server will be mapped with public IP it is upon you which you want make internet facing.

One which is not mapped with public IP configure all Exchange virtual directories authentication method to Integrated Authentication rather Form based. also remove external URLs from non-internet facing exchange server and restart IIS then try it will work.

If you want to understand about CAS Proxying an Redirection please read this article
accessgroupAuthor Commented:
Thanks for that read.

It's weird. My issue is a lot like this guys,

and I've followed his results and nothing.

I've also found this and followed it, again nothing.
accessgroupAuthor Commented:
Just FYI both sites use Exchange 2007, I'm not able to upgrade either 2010+

I just want CAS proxying to work :)
accessgroupAuthor Commented:
My error was in the IIS permissions on the LAN facing CAS. Changing those to Windows Authentication has fixed both my Active Sync and OWA

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
accessgroupAuthor Commented:
Through trial and error found a setting in IIS.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.