Exchange 2013 Autodiscover

Hi Guys I have posted a similar Question but not getting much help here.

If I Run get-outlookprovider I get the following


they are all blank??

So I have a question if they are Blank where is Autodiscover Getting its settings from?

Plus I may need to Change EXPR and I am worried that if I do it may cause disruption so what would be the command to put it back as above??
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Leroy LuffHead of IT & DIgitalCommented:
1. Test-OutlookWebservices -  to test Autodiscover.

2. Get-ClientAccessServer | FL AutoDiscoverServiceInternalUri - To see Autodiscover URL

3. Set-ClientAccessServer -Identity SERVER -AutoDiscoverServiceInternalUri - To set Autodiscover URL
pepps11976Author Commented:

Test-OutlookWebservices comes back with an error --- Unable to find the client access monitoring user

Get-client accessserver returns hosting.domain.local
Leroy LuffHead of IT & DIgitalCommented:
Seems its not authenticating.

Try : Test-OutlookWebServices -MailboxCredential:(Get-Credential domain\username)

Regarding the Get-client accessserver - this is wrong. should be which should resolve to localserver.domain.local. Use the cmdlet i gave you above to correct this.

Make sure you have a DNS entry that points to Exchange. Do you have more than 1 exchange 2013 server?
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

pepps11976Author Commented:
If I explain my issue it may become clearer

We have an Exchange 2013 Server that hosts a company's email, they are all External Users, everything works fine except for 2 users who are using Windows XP and Office 2007, both with latest Patches.

Only the XP users have the issue where if they open Outlook they are continually asked for Password, now I believe this is because XP users will only read the The subject Name in the Cert and not the associated SAN's.

so my thought is if I were to change EXPR to be the Subject name of the Cert then they would not be asked for credentials any more.

My worry is if I change that will it cause issues to the users working ok???
pepps11976Author Commented:
When trying the Test autodiscover I got Result Failure

the service Endpoint is pointing to a .local, my domain is a .local domain if that helps shed light on anything?
Leroy LuffHead of IT & DIgitalCommented:
Are you 100% Office 2007 is fully patched? It will not work without all latest patches.

Please download this tool to check your office -

I have had the exact same issue before with 3 XP computers and I resolved it my filling in the Exchange Proxy settings in Outlook manually and installing the certificate.

However that being said these users should immediately move away from XP and office 2007. It is obsolete and prone to give issues.
Leroy LuffHead of IT & DIgitalCommented:
For troubleshoot Autodiscover error do the follwing :

Test-OutlookWebServices -MailboxCredential:(Get-Credential domain\username) | fl >> TestResult.txt

Browse to the directory you ran this command from and open the txt file you created. In that log file you will be able to see why it is failing. Post it here if you need help.
pepps11976Author Commented:
I have attached the .txt file


Although I am thinking this may be another issue and not the question I need answering
Leroy LuffHead of IT & DIgitalCommented:
That error there just shows that the account you are using to test with is not authorised to do that test. Autodiscover is most likley working as you said other users do not have an issue,

I still stick by my answer of checking latest patches for 2007. It will not work without it.

You can also try to manually enter exchange proxy settings. Do you know how?
pepps11976Author Commented:
Ok Just to confirm All latest Patches etc are installed

on the XP Clients msstd: is set to, im think if I could change this to to subject name it will work. these setiings get populated once It connects to exchange I do not put anything in the msstd: part

if I manually change it in Outlook settings it just goes back once restarted
Leroy LuffHead of IT & DIgitalCommented:
I do not think that will resolve your issue as it is working for other clients.

The msstd : should be and this setting comes from Outlook anywhere in Exchange 2013.

Keep this question open another day as there might some1 else who can shed light on this.
pepps11976Author Commented:
Yes but if XP only reads the subject name which is

and is entered as a Subject Alternate Name then that would cause Password Prompts?
pepps11976Author Commented:
ok I have managed to solve this by forcing Settings

To force the value I used the following Group Policy Administrative template to manage the RPC/HTTP settings for Outlook 2007 clients:

Article 961112 Policy Settings

this way I do not need to mess around with exchange

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pepps11976Author Commented:
Found Answer myself
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.