remote desktop issues

Hi,

I keep receiving this message when I connected to my newly build VM standalone server below.

" the connection has been lost attempting to reconnect to your session" and it hangs all the time.

any idea please.

Jess
JessIT2013Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

btanExec ConsultantCommented:
May want to consider it as mostly due to a network or h/w

- Verify latest updates to the server specifically to NIC firmware, BIOS, NIC drivers, chipset drivers, etc.  e.g. any NIC power management features disabled in the adapter settings in Windows as well as in the server BIOS (if the option exists).  Check setting for link speed if it is set to Auto if it is not already as a test. Include checking on another different switch port to avoid h/w failure like faulty port and even cable and its patching .

- Verify if RD Keep-Alives is turned on and also do restart for changes done already in your server.  See GPO setting in "Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections" > Configure keep-alive connection interval     Enabled, and  Keep-Alive interval:  1

- Avoid having any NIC features like teaming, failover config, offloading etc for isolation testing. There may be more to disable but common one are those, see if there are other to disable for a start.
Lionel MMSmall Business IT ConsultantCommented:
Can you connect to the physical server (hyper-v or vmware) without any of these issues? if yes then it is not a hardware issue (switch, router, network card, cabling) but it has to do with the software side of it--in this case make sure you have the latest "integration services" installed http://www.howtonetworking.com/server/hyper-v16.htm. However if the problem is on connect to the physical server too then you need to check the hardware.
WORKS2011Austin Tech CompanyCommented:
run ipconfig /flushdns

try using IP address, if you can connect it's a DNS issue.
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

btanExec ConsultantCommented:
always good to make sure the VM windows FW is not blocking rdp connection
The remote computer had its RDP-port changed from 3389 to 443 to bypass firewall restrictions from the corporate network. This would case certain Windows features to misinterpret the traffic and interfere with the connection.

Anyway, the cause for my specific issue was “Windows Auto-Tuning” (first introduced in Windows Vista), it was breaking (“optimizing”) the remote desktop traffic.
To shut this feature off simply open a command-prompt with elevated privileges and type:>
netsh interface tcp set global autotuninglevel=disabled
There is no need to reboot your computer, it will turn the feature off immediately.
To re-enable the feature write:> netsh interface tcp set global autotuninglevel=normal
... and have client and server at the latest patch prior to testing.
You run an application that connects remotely by using a TCP connection on a computer that's running Windows 8, Windows 8.1, Windows Server 2012, or Windows Server 2012 R2. If the TCP connection uses ephemeral (short-lived) loopback addresses, the connection may be dropped suddenly after 40 to 50 seconds. However, the TCP connection is still "live" from the client side. In this situation, the application does not maintain the remote connection.
make the ping is alright first or maybe just have another VM client instance in same physical server for quick local test to isolate off those potential physical network  complications.
JessIT2013Author Commented:
not just windows 7 or 8 . even from windows XP..I still have problem connecting remotely to the server? does it got to do with DNS?
btanExec ConsultantCommented:
To isolate, it will then to use the RDP server IP address directly instead of hostname.
If you find yourself having name resolution problems, there are a couple of different things that you can try. One option is to try using the remote system's fully qualified domain name as opposed to its NetBIOS name. This won't always help you to establish a connection, but in certain situations it will help.

Another option is to specify the remote machine’s IP address rather than its name. Generally speaking, using an IP address tends to be much less problematic than using a host name when connecting. Even IP addresses can be problematic, though.

The biggest factor that tends to make connecting with IP addresses problematic is the use of dynamic IP addresses. If you are using Remote Desktop to connect to a server, this probably won't be an issue, because most servers use static IP addresses. Workstations, on the other hand, almost always use dynamic IP addresses. Therefore, the IP address that your workstation is using today will probably be assigned to a different workstation tomorrow. If the machine that you are connecting to does use dynamic IP addresses, then you will practically have no choice but to specify a host name when connecting rather than specifying the machine's IP address.
http://www.windowsnetworking.com/articles-tutorials/trouble/Troubleshooting-Remote-Desktop.html

in short, try connecting to an IP address rather than a computer name.  Use ping to test the network connection, if there is a problem check the Host records at the DNS server. If you have selected Network Level Authentication (NLA) then you must type the full computer name at the client.  For example mycomputer.local and not plain mycomputer.  If in doubt, try ping mycomputer.  The surest alternative is to check in the Control Panel, System and Security, System:  Full computer name.

I am thinking if an VM instance of the RDP client is setup fresh in the same physical host running  the RDP server instance, will this even work (so as to isolate off all the external physical connectivity or possible oversight or misses. Also best to keep the RDP server to its latest patch and SP patch
JessIT2013Author Commented:
I am using a remote desktop to connect to our servers. Our servers has static ip. I do not have problem with my other servers or other VMs machine connecting remotely. Only this one server. What about DNS records?

thanks,
Jess
btanExec ConsultantCommented:
Can you even connect using the actual ip instead of dns as I mentioned prev n also ping befire hand
JessIT2013Author Commented:
I am using windows 2008 r2 server and windows XP, windows 7 pro for desktops. tried both and have the same problem.
Lionel MMSmall Business IT ConsultantCommented:
Did you check the firewall and the integration services?
btanExec ConsultantCommented:
Can try unchecking Allow connections only for computers running Remote desktop with Network Level Authentication.

Check Windows Firewall exception that is added by default when RDP is enabled, it is only for the private network so for if using any of it as the public network, then try to manually enable the public rules. Do enble all the rules again to allow rdp on server.

Need to make rdp server is joined to the same domain and subnet too minimally.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JessIT2013Author Commented:
i am using IP address to connect. Pinging is working fine.
btanExec ConsultantCommented:
So rdp is alright for ip. Otherwise what is the event viewer log for this server as I even think that it has dns issue error earlier in log..can re-assigned the static ip and do a ipconfig /flushdns on that network adaptor card..
JessIT2013Author Commented:
I even disabled the firewall both private and public. This server is not on a domain. I have 3 of them but others no issue.

I am using " allow connections from computers running any versions of remote desktop. (less secure)"
JessIT2013Author Commented:
Lionelmm,

where can i find the intergration services you have mentioned?

Btan,

i tried ipconfig/flushdns - nothing changed. I do not have dns installed in this server.
Jess
btanExec ConsultantCommented:
consider it for domain instead. Can do a netstat or use portqry to check if the TCP3389 is open.
To download portqry, can check out http://www.microsoft.com/en-us/download/details.aspx?id=24009

For info, the default port is 3389. You can even change the VM machines into having different port no such as 3389, 3390 and 3391. Regardless, the listening port in registry key on each VM server machine can be found under HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber

So if the TCP port 3389 is blocked, please re-enable the firewall rules again. But if those TCP port 3389 is open, then back to RDP issue. Have to drill into the event log of terminal services. We need to know the specific for dropping RDP request.

Otherwise if no clients can or have connected to this rdp server before then rebuild it then. There maybe file corruption problem. If there is indications from this test VM giving disk problems e.g. sfc /scannow reveals errors.
Lionel MMSmall Business IT ConsultantCommented:
integration services
in the VM console on the Hyper-V (direct connect, not RDP)
Action Menu, last item on that menu insert integration services
then on VM settings (right click on VM list in Hyper-V Manager, under Management, check which services are checked
Anand PandyaCommented:
Some times small mistakes take very long time to resolve it. If there are any such connection issues. I would just recommend to check the time zone on both host and virtual machine on which you are connecting. The time zone and time must be in sync with host as well as virtual server.
Because if you are able to ping the server and remote the server via IP then this might be the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.