Windows 7, Adobe Flash Player and Internet Explorer 11

We have a couple web-based programs that we use.  Both require Adobe Flash Player.  On Windows XP, this works fine.  When using Windows 7 and Internet Explorer 11, they will only work if the user logged in is in the computer's Administrator group.  The one application just hangs.  For the other we get message: Player initialization failed.

Tried using Google Chrome but the prompts to allow access are cumbersome at best.  Is there some folder that everyone needs access to or is there another solution to this?  Thanks!
sfsdtcAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
Hi.

And with xp, did you run as administrator or power user or restricted user?
0
sfsdtcAuthor Commented:
In XP they were normal domain users
0
Brian PringleSystems Analyst II, SCM, ERPCommented:
Flash player resides in C:\Windows\system32\Macromed folder.  I would check the permissions there.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

McKnifeCommented:
"normal domain users" is not really an answer. I mean, had they been added to a local group other (or in addition) to the standard users group?
0
sfsdtcAuthor Commented:
Sorry, meant that the students are just in the Users group on the local computer when this doesn't work.  If I add them to the local Adminstrators group, then it works.

I tried giving everyone full permissions to the C:\Windows\system32\Macromed folder but that didn't work.  I also saw an item regarding registering the .ocx file in that folder.  However, the user doesn't have premission to use the regsvr32 command (get error that call to DllRegisterServer failed with error code 0x80070005).  If I log in as an administrator, run the regsvr32 command on that .ocx file, it works but then when I log back in as a student, still get Player Initialization Failed message.
0
McKnifeCommented:
These applications, do they claim to be compatible with standard user rights? You should tell the manufacturer that they are not, he might offer a solution.
0
sfsdtcAuthor Commented:
Tried contacting them.  Their only recommendation was to use Google Chrome intstead.  Chrome works; however, the prompts to allow access are kind of hidden.  For students to try to figure out where the prompts are to be able to continue onto the application is frustrating and time-consuming for them.

For now I'm just adding the domain student group to the computers' local Administartors group as this works and there if been few issues with this.  However, I'd prefer if there was a better solution for this.

If you believe this is a vendor-specific problem then there probably is no solution and I'll close this issue.
0
McKnifeCommented:
For sure it is vendor specific. Flash never needs admin rights.
Use a monitoring tool, best is procmon, to record what is going on. Save a log and search that log for "access denied".

Would be better to solve it, making them admins is a no-go.
0
Brian PringleSystems Analyst II, SCM, ERPCommented:
I would not make them admins, unless you absolutely have to do it.  What happens if you make them Power Users?
0
McKnifeCommented:
The power users group has been deprecated starting with windows vista. No use adding them.
0
sfsdtcAuthor Commented:
I did actually try adding them to Power Users which didn't work.  When I researched this I did see where Power Users group is only there for legacy apps and doesn't actually do anything.

I've downloaded Procmon and will run it to see what it shows.
0
sfsdtcAuthor Commented:
While logged on as a student, tried running Procmon but said must be logged on as administrator.  I tried right clicking then Run as administartor but got same error.
0
sfsdtcAuthor Commented:
I tried using Process Explorer from Sys Internals as it was able to run as a non-admin.  However, I didn't see that it showed anything that would tell me where the problem is.

Could this issue be some kind of non-admin IE11 setting?
0
McKnifeCommented:
start procmon as admin/ via runas, then provoque the error. It logs for all users.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sfsdtcAuthor Commented:
Unfortunately, nothing worked to fix this except using Chrome or setting users as administartors
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.