I need to locate and import an exchange applet

I recently, a couple days ago, installed the remote exchange server tools for exchange 2010, on a windows 7 machine. When I open the exchange console it defaults to the wrong exchange server, we have a farm. WHen I click on the properties and try to connect to another server I get and error:

The term 'Get-ExchangeServer' is not recognized as the name of a cmdlet, function, script, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

I am new to the powershell, well not exactly new as I have shunned it since its conception, and I am now studying the powershell for the first time.

I tried running the get-exchangeserver command from my regular powershell and the exchange enhanced powershell and it failes on both. When I run the script from the exchange server's regular power shell it fails, but when run under the excahnge modified shell it works perfectly.

I though I would just copy the script to my local win 7 PC, but I can not find this command/script.

Can anyone help me out here :)

thanks
newmanme
LVL 1
newmanmeNetwork Administrator\EngineerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
Did you make sure that all of the services are running on your windows machine? Have you tried to re-install the Management Tools? Are you using the Exchange Management Shell rather than the standard Powershell interface?

Do the above first.

Will.
Guy LidbetterCommented:
when you open the exchange console, before you try change servers, does the console appear to work properly?
newmanmeNetwork Administrator\EngineerAuthor Commented:
Good morning and thank you for the comments.

The command does not run from the exchange enhanced powershell either. I figure that a module is not loaded or something to that extent.

I did figure out how to make a remote connection to a different server via powershell, but it would be nice to be able to switch to the other exchange servers (they have different roles) using the console.

Matt
Guy LidbetterCommented:
In order to load the module in a normal Powershell session, run this:

Add-PSSnapin *Exchange*

Open in new window

This is assuming the management tools have been successfully installed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.