Windows Server 2012 running on VMware time syncronization ntp

Hi Guys,
I have a Windows Server 2012 PDC running on VMware vSphere 6, brand new installation, first in the forest.

I'm getting a warning message (see below) but I'm confused because in the olden days I would just force the server to synchronize with some stratum 2 servers somewhere in the Internet.

But now that the server is a virtual machine, I have read that the Windows Server is synchronizing its time with VMware, I don't know about that.

What is the b est way to deal with this warning?

Log Name:      System
Source:        Microsoft-Windows-Time-Service
Date:          7/28/2015 3:38:41 PM
Event ID:      12
Task Category: None
Level:         Warning
Keywords:      
User:          LOCAL SERVICE
Computer:      MYCOMPUTER.domain.local
Description:
Time Provider NtpClient: This machine is configured to use the domain hierarchy to determine its time source, but it is the AD PDC emulator for the domain at the root of the forest, so there is no machine above it in the domain hierarchy to use as a time source. It is recommended that you either configure a reliable time service in the root domain, or manually configure the AD PDC to synchronize with an external time source. Otherwise, this machine will function as the authoritative time source in the domain hierarchy. If an external time source is not configured or used for this computer, you may choose to disable the NtpClient.
cargexAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Be sure you install VMware Tools in the guest machine. In Tools there is Time Synchronization function and you can sync the time in the guest to the time in the host machine.
0
Seth SimmonsSr. Systems AdministratorCommented:
you need to configure that server as a time server to sync with external ntp server

this article shows how to do that

How to configure an authoritative time server in Windows Server
https://support.microsoft.com/en-us/kb/816042

also, make sure time sync is disabled in vmware

Configure Time Synchronization Between Guest and Host Operating Systems
https://pubs.vmware.com/vsphere-50/index.jsp?topic=%2Fcom.vmware.vmtools.install.doc%2FGUID-C0D8326A-B6E7-4E61-8470-6C173FDDF656.html
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zephyr ICTCloud ArchitectCommented:
The server is not synchronizing it's time with VMware automatically, that's a setting, but I'd (my preference) rather use an external ntp source, like the "olden days" ;-)

So it's just like before, either use a reliable "in-house" time source (maybe a router or something that is synching with an outside ntp source) or directly configure the server to sync with an outside ntp source.

The same goes for your VMware hosts, they have an ntp client as well, best practice dictates to configure these as well, because even when time synchronization (with VMware) is disabled on the client , it can still influence the client in certain events.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

zalazarCommented:
Best practice for AD PDC's on VMware is to disable the VMware time synchronization and configure it to an external NTP source.
First disable time sync in VMware as already mentioned by Seth Simmons.
There is also an option to disable Time Synchronization completely but if you configure your VMware hosts also to the external NTP source then I would actually not recommend to do this.

After that configure Windows Time by opening a command prompt (cmd.exe) and:
w32tm /config /manualpeerlist:"<dns name of external source>",0x8 /syncfromflags:MANUAL /reliable:yes /update

Open in new window

Execute a resync and rediscover via:
w32tm /resync /rediscover

Open in new window

Check the Windows System eventlog if the time sync was successful.
0
frankhelkCommented:
It's never a good idea to have two services (W32time and VMWare time sync) manage the clock together.

So - as told before - you should disable the VMware time sync.

Furthermore, I've experienced enough trouble with W32time to avoid using it whenever I can.

My recommendation:

Use a Windows port of the classic *ix NTP service. The classic NTP service software is free. Easy to install and configure, works like a charm and is stable as a rock. And it is nicer when it comes to one of the rare cases of troubleshooting.

See this article for the "How To".
0
cargexAuthor Commented:
Thanks guys!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.