Oh no! Windows 10 RDP client windows are again being glued to the upper left corner of the screen

We had this stupid issue in Windows 8 where new (or maximized) RDP windows got glued to the upper left corner automatically.
This was resolved in windows 8 by going to Ease of Access Center, then going to "Make the mouse more difficult to use" (sorry, "Make the mouse easier to use") and then checking "Prevent windows from being automatically arranged when moved to the edge of the screen".

Unfortunately, this does not work in Windows 10.

Being an intense user of Remote Desktop, this is extremely annoying.
Anybody with a fix for this?

(I know, cutting edge makes you bleed, but still...)

Thanks,

Bjorn
Bjorn DirchsenSysAdmAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

McKnifeCommented:
I am a more than excessive user of RDP and use win10 for quite a while now, before I used 8.1 - what has changed? I don't notice it at all and see no problems. How would you like the new windows to look?
Bjorn DirchsenSysAdmAuthor Commented:
McKnife. If you Maximize a window, it jumps to the top-left corner of the screen and can't be moved unless you either double-click the title bar or the Restore icon in which case the window is no longer maximized and you then have to manually expand the window size with the mouse.
In Windows 8 (after making the changes in the Ease of Access Center), you could Maximize a window and then drag it to any other position on screen and the window stayed maximized.
McKnifeCommented:
Doesn't happen for me, ever. Just as it was with 8.1, I have it with 10.
Check if if gets better when you use the display option "full screen".
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

Bjorn DirchsenSysAdmAuthor Commented:
McKnife.
I disagree with you :)

I'm using a saved profile. When I double-click the RDP file and enter my login creds, the window opens up, Maximized. In Windows 10, it's glued to the top left corner and cannot be moved away from the corner.

In Windows 8.1 (using the same RDP file), the window also opens up, Maximized. But I can move the window away from the top left corner. When moving the window, it immediately goes from maximized to restored size

UNLESSS I make the changes in Ease of Access Center as described in my initial post. If I do that, I can move the maximized window away from the top left corner and around on the screen without performing any steps and the window stays maximized.
And this is how I want it work. Having connections to multiple servers at the same time is what I do on a daily basis, so I always would want the Remote Desktop windows to be maximized and be able to move them around on the screen.

The behaviour IS different.
McKnifeCommented:
Ok, for you it is different.
Could it be, that it only happens with saved rdp files and not with new manual connections? Tried that?
Bjorn DirchsenSysAdmAuthor Commented:
McKnife,
True, I've only tested it on one W10 machine (I only have a single W10 at the moment).
The behaviour is almost the same when connecting manually and maybe i should ditch my 66 RDP files.

If I DO NOT use an RDP file, It remembers the size of the non-maximized window (which in my case is equal to a maximized window) the next time I connect. The RDP file does not remember the size or at least - it behave differently on my W10 box.

Just for fun, I tried changing the line

winposstr:s:0,3,0,0,800,600
to
winposstr:s:0,1,0,0,5000,5000

Translated into human language:
Maximized (the "3" parameter) with a non-maximized size of 800x600 pixels
to
Windowed (the "1" parameter) with a non-maximized size of 5000x5000 pixels.

It does not create a 5Kx5K window though. The size of the window is defined elsewhere in the RDP file:

desktopwidth:i:1366
desktopheight:i:768

But i'd rather not go through my 66 RDP connections to change this :-{

Bjorn
McKnifeCommented:
Oh, changing the rdp files is like editing text files, should work.
Look at this little batch, it can change text.
powershell -Executionpolicy ByPass -Command "&{$file = 'c:\test.rdp' ; (gc -path $file | Out-string).replace('before','after') | Set-Content -path $file}"

Open in new window

Combine it with a for loop and there you go, all files edited automatically.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Bjorn DirchsenSysAdmAuthor Commented:
Minor detail. When executing the line from a command prompt, powershell disliked the ampersand.
So I ran:

powershell -Executionpolicy ByPass -Command {$file = 'xxx.rdp' ; (gc -path $file | Out-string).replace('winposstr:s:0,3,0,0,800,600','winposstr:s:0,1,0,0,5000,5000') | Set-Content -path $file}

Open in new window


...instead
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.