Error setting up a new Cisco router C881-K9

After up loading a new BIN file i get this error.
*** No sreloc section!!!FATAL ERROR : Unknown controller type 2964!!!FATAL ERROR
 : Unknown controller type 2964

 Unexpected exception to CPU: vector 1400, PC = 0x9AE4914 , LR = 0x5560E04


Its a Cisco 881 i used "
c800-universalk9-mz.SPA.153-3.M.bin
c800-universalk9-mz.SPA.154-1.T.bin
c880data-universalk9-mz.124-24.T4.bin
any i get the same error if a load any of the bin file listed above .
Pat ParigiIT leadAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JustInCaseCommented:
You have loaded old IOS, but did you set it to boot, and not to boot version 15. I hope you have backup of original IOS.
Replace boot image from rommon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pat ParigiIT leadAuthor Commented:
I have tried these ios and i get the same problem.

c800-universalk9-mz.SPA.153-3.M.bin
c800-universalk9-mz.SPA.154-1.T.bin
c880data-universalk9-mz.124-24.T4.bin

and i have 5 Cisco router that this happens on.
Pat ParigiIT leadAuthor Commented:
It is now fixed I installed this ios.
c800-universalk9-mz.SPA.154-3.M2.bin

Thank you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.