Autodiscover finds old onsite server in outlook

I have added the items in the registry for 8 PCs but one will just not work. It STILL goes to the old server instead of 365

How can I disable it or have it come up with only the 365 settings?

Thanks
lbat40Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sudeep SharmaTechnical DesignerCommented:
Hi lbat40,

Why are you making the changes in the registry? You should have get the autodiscover to work on all the PCs through DNS.

So from the system on which you are facing issue what do you get when you run the following on the command prompt
nslookup autodiscover.yourdomain.com
(replace yourdomain.com with the actual domain in question)

Further, have you disabled the autodiscover from the local exchange?

Sudeep

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simon Butler (Sembee)ConsultantCommented:
Is the old server in place still? If you have migrated to Office365 then remove Exchange completely.

As an interim measure you could enter the following:

set-clientaccessserver servername -AutodiscoverServiceInternalURI https://host.example.com/Autodiscover/Autodiscover.xml

where servername is the name of your Exchange server, and host.example.com is the name that Office365 have given to you for Autodiscover.

That will force the clients that do find the Autodiscover records in the domain to query Office365.

However long term the best option is to remove Exchange from the internal network.

Simon.
Radhakrishnan RSenior Technical LeadCommented:
Hi,

I have faced the same issue some times ago. It was due to the Autodiscover entry in sites and service. I have removed the service connection point to the old exchange server which resolved the issue.

Active Directory Sites and Services>>Click the View menu in the 'Active Directory Sites and Services' window and select Show Services Node>>Expand Services, Microsoft Exchange, Administrative Groups, Exchange Administrative Groups, Servers, <Exchange server name>, Protocols, Autodiscover.
In the right-hand pane, right-click the object of type 'serviceConnectionPoint' with <your Exchange server name> (if the option exists) and select Delete.

Note: Please do not delete the nodes Servers, <server name>, Protocols and Autodiscover instead delete the serviceconnection point.

Hope this helps.
lbat40Author Commented:
Hi Guys

Thanks for the comments thus far. As it was late last night when I finished I just installed a new PC! For whatever reason it was down to the actual computer itself. I tried creating a new user and it still did the same thing and it was one out of 13.

I will review answers but in readiness for my next question, all accounts are now with 365, business premium, which includes exchange too.

I exported all users ost files including contacts, tasks, calendar and emails to the 1 pst file and saved locally.
I then removed the accounts from outlook off the local server and added them with the 365 details. All but one worked fine, as you all know.
I then imported the pst files into users relevant accounts.
That's where I am now, although there are one or two issues obviously still being picked up from the server end.
So I don't want anything at all to do with exchange on the local server, or do I?

They have email internal and external, share calendars and contacts and that's it. 13 or 14 accounts in total.
I would like to give the then server left, a little less work to do!

I guess I only want the server to print, share folders, and they have a program that's links to sage products. It should be running much quicker...which isn't the reason totally for going to 365 but is one of them.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.