Windows 10 Lock screen issue for domain members

We have updated a number of PC's on our domain to windows 10.  We have a global  group policy to enforce a screen lock out after 15 minutes as part of our PCI compliance.

We have noticed a change in behaviour when unlocking a PC.  If the operating system is Windows 7, or 8 or 8.1 then you only have to enter your password to unlock the PC.  With Windows 10 you have to enter both your username and your password.

Is there a way to revert to only having to enter your password, as the extra typing appears to be annoying our directors ....


regards


Spencer Clark
vodyanoiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Justin StearCommented:
I don't have Windows 10 on any computers yet, but a quick search shows this good tutorial for Win 8.  I don't see anything for Win 10 yet.  Check this and let me know if it helps:
http://www.eightforums.com/tutorials/19418-lock-screen-sign-user-name-password.html
0
Wayne88Commented:
Can you try this:

Type secpol.msc in Windows Start Search and hit Enter. This will open the Local Security Policy Editor. Navigate to Security Settings > Local Policies > Security Options.

Now on the right hand side, look for Interactive Logon: Do not display last username. Right click on it and open its Properties. Set it to Disable > Apply.
0
JohnBusiness Consultant (Owner)Commented:
I think you must enter name and password. The login is different but in my own Windows 10 machine (not on domain) the user name remains.

There is a registry key to retain user name or not in Windows 7 and 8.1 that you can check. I will see if that setting is in my Windows 10 machine.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

McKnifeCommented:
Wayne's comment is it. We noticed the same. Win10 is weird, at this spot.
0
JohnBusiness Consultant (Owner)Commented:
Please let us know about the interactive login key. It works as expected on my Windows 10 machine, but it is not on a domain.

Is your domain Server 2012?
0
Wayne88Commented:
If it's on the domain then simply set the same in the group policy applicable to this machine.  This will ensure for all future W10 setup that the usernames are displayed.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
McKnifeCommented:
To clear this up:
The GPO "don't display last username" is not activated by default, but many do it for security reasons. The resulting behavior is different for windows 10 as compared to ALL versions before:

Windows 10: shows no last username when you start the machine + shows no logged on user when you try to unlock it
Windows-before-10: shows no last username when you start the machine but DOES show the currently logged on username when you unlock.

I have to say that this design change is inconvenient for mixed environments (win7+8.x+10). But from a security perspective, it's consistent and only logical - we don't want an attacker to see who is using the machine - no matter if he starts or tries to unlock it. Before win10, this was only possible for starts but not for unlocks.
0
vodyanoiAuthor Commented:
Followed Wayne88's idea and added a group policy to cover this.  Works perfectly.

McKnife - I agree, from a security perspective, not showing the logged in user name is the preferred choice.  However, I sit 1 meter from our MD and keeping him happy is far better for my sanity.
0
McKnifeCommented:
"However, I sit 1 meter from our MD and keeping him happy is far better for my sanity." - I see :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.