SCCM 2012 R2 SP1 WSUS issue

Leon Taljaard
Leon Taljaard used Ask the Experts™
on
Hi Guys,

I am having an issue with my WSUS on SUP server, i keep getting an error in my WSUSCtrl.log as shown in the attached image, i have tried updating the WSUS to the latest patches but nothing I have tried has worked so far. Any suggestions would be appreciated.

Capture-WSUS.PNG
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Thomas GrassiSystems Administrator

Commented:
0x80131701 means that failed to find a required export in the runtime.

Is there any warning or error in the WSUS server? If yes, please post it here.
Leon TaljaardSystem Center Specialist - Architecture

Author

Commented:
Hi Thomas,

I managed to get rid of the error by removing .net 4.5.2 and installing .net 4, this seemed to get everything working again.

the only issue I have now is that the updates are not actually downloading to the WSUSContent folder, but SCCM says it downloaded and processed the updates.

This is a reinstall of a crashed WSUS setup so i am not sure if there might be something else wrong.
Thomas GrassiSystems Administrator

Commented:
Run wsusutil checkhealth from a command prompt on the ways server then check the application log for the message results

On the wsus server check the sync process

Did you move the folder?
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

Leon TaljaardSystem Center Specialist - Architecture

Author

Commented:
The only thing i get back from running that is "No client computers have ever contacted the server."

I think i need to remove all the roles and uninstall WSUS, reboot the servers and then possibly try again.

I see a whole lot of expired updates from the previous install that are still there and have not been removed even though they are not in any update groups.
Systems Administrator
Commented:
From the clients run this
wuauclt.exe /resetauthorization /detectnow


Give it sometime to register

Uninstall wsus as a last resort
Leon TaljaardSystem Center Specialist - Architecture

Author

Commented:
Hi Thomas,

Apologies for the late response, i am checking the server now and will get back to you ASAP
Leon TaljaardSystem Center Specialist - Architecture

Author

Commented:
Hi Thomas,

it seems to be working now, but just a quick question. Once the secondary is working do the SCCM clients at the secondary automatically get a policy change to connect to the local secondary SUP or would i need to force them with a GPO per site ?

Thanks
Thomas GrassiSystems Administrator

Commented:
Glad to hear it is working

If your domain does not have any issues with gpo syncing they computers should be ok in time. But if your impatient then do a force. Then check with gpresult /r or rsop
Leon TaljaardSystem Center Specialist - Architecture

Author

Commented:
Hi Thomas,

I know I have already marked the answer but would you perhaps know why my one Secondary site just has this in its "wsyncmgr.log"

Capture.PNG
Do i just need to wait

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial