Error when installing Exchange 2013 (in an existing Exchange 2010 environment)

During the setup of the mailbox role, the Exchange 2013 installation wizard returned the following error and halted...

[07/30/2015 16:32:29.0946] [1] The following error was generated when "$error.Clear();
          if (!$RoleIsDatacenter -and !$RoleIsDatacenterDedicated)
          {
            $createNewOab = $false;
            $oabName = $null;
            $oabAddressList = $null;
            $oabVdirs = $null;
            $oabGlobalWebDistribution = $false;
            $oabConfiguredAttributes = $null;

            Write-ExchangeSetupLog -Info ("Looking for an existing default OAB");
            $defaultOab = Get-OfflineAddressBook -DomainController:$RoleDomainController | where {$_.IsDefault};
            if ($defaultOab -ne $null)
            {
              Write-ExchangeSetupLog -Info ("Found a default OAB: " + $defaultOab.Name + "; checking its version");
              if ($defaultOab.ExchangeVersion.CompareTo([Microsoft.Exchange.Data.ExchangeObjectVersion]::Exchange2012) -lt 0)
              {
                $e15Oab = Get-OfflineAddressBook -DomainController:$RoleDomainController | where {$_.ExchangeVersion.CompareTo([Microsoft.Exchange.Data.ExchangeObjectVersion]::Exchange2012) -eq 0};
                if ($e15Oab -eq $null)
                {
                  Write-ExchangeSetupLog -Info ("Existing OAB is Exchange 2010 or older; will create a new OAB");
                  $createNewOab = $true;
                  $oabName = $defaultOab.Name + " (Ex2013)";
                  $oabAddressList = $defaultOab.AddressLists;
                  $oabGlobalWebDistribution = $defaultOab.GlobalWebDistributionEnabled;
                  $oabConfiguredAttributes = $defaultOab.ConfiguredAttributes;
                }
                else
                {
                  Write-ExchangeSetupLog -Info ("Already has an existing Exchange 2013 OAB:" + $e15Oab.Name + "; will not create a new OAB");
                }
              }
              else
              {
                Write-ExchangeSetupLog -Info ("Existing OAB is Exchange 2013 or newer; will not create a new OAB");
              }
            }
            else
            {
              Write-ExchangeSetupLog -Info ("Did not find a default OAB; will create one");
              $createNewOab = $true;
             
              $oabName = [Microsoft.Exchange.Data.Directory.SystemConfiguration.OfflineAddressBook]::DefaultName;
              $nonDefaultOabWithDefaultName = Get-OfflineAddressBook $oabName -DomainController:$RoleDomainController -ErrorAction SilentlyContinue | where {$_.IsDefault -eq $false};
              if ($nonDefaultOabWithDefaultName -ne $null)
              {
                $createNewOab = $false;
                Write-ExchangeSetupLog -Warning `
                  ("Offline address book " + `
                  $nonDefaultOabWithDefaultName.Name + `
                  " already exists: " + `
                  $nonDefaultOabWithDefaultName.DistinguishedName + `
                  ". Use administrative tools to change it to default OAB.");
              }

              $allGals = @(Get-GlobalAddressList -DomainController:$RoleDomainController | where {$_.IsDefaultGlobalAddressList});
              if ($allGals -eq $null -or $allGals.Count -eq 0)
              {
                $createNewOab = $false;
                Write-ExchangeSetupLog -Warning `
                  ("Couldn't find the default global address list. The default offline address book can't be created.");
              }
              elseif ($allGals.Count -gt 1)
              {
                $createNewOab = $false;
                Write-ExchangeSetupLog -Warning `
                  ("Found " + $allGals.Count + " default global address lists. You can have only one default global address list in your organization. The default offline address book will not be created.");

We do have two global address lists.  One is named Default Global Address List and the other is Company Name Addresses.

I am not able to browse/edit our public folders using the Public Folder Management Console for some reason.  It indicates it is not connected to a server, and I cannot manually connect to either of our two Exch 2010 HT/CAS/MB servers.
MatthewDKAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Schnell SolutionsSystems Infrastructure EngineerCommented:
Do you have more than one Global Address List as default?

Please, execute the following commandlet in EMS:

Get-GlobalAddressList | Format-List Name,IsDefaultGlobalAddressList

If this is the case, Let's ensure that just one appears showing "True". If not, we will set it for having just one default GAL
0
MatthewDKAuthor Commented:
The Default Global Address List comes back as True while the other comes back as False.
0
Schnell SolutionsSystems Infrastructure EngineerCommented:
Which ones are the names? and how many?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MatthewDKAuthor Commented:
Here's what the output of the command you suggested I use is...

Name                                        : Default Global Address List
IsDefaultGlobalAddressList  :  True

Name                                        :  Company Name Addresses
IsDefaultGlobalAddressList  :  False
0
Schnell SolutionsSystems Infrastructure EngineerCommented:
Let's allow that Exch 2013 creates its OAB using its default name. In this case we can rename the one used for Exch 2010 at the moment.

You can change this name with the following command let in EMS:

Set-OfflineAddressBook "Default Global Address List" -Name "Default Global Address List 2010"
0
MatthewDKAuthor Commented:
We do not have an OfflineAddressBook named Default Global Address List. I've attached the output from the command Get-OfflineAddressBook | fl.  In that file, OAB2 is the offline address book that is assigned to our mailbox databases.
OfflineAddressList-output-2.txt
0
Schnell SolutionsSystems Infrastructure EngineerCommented:
Good. Did you notice that the first OAB is pointing to a deleted or non-existing DB. We need to resolve this issue. We have many options here:
- Mount the missing DB
- Delete that OAB if is not in use and is not referred to any mailbox database
- Quit that it saves/publish its information into the deleted DB
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MatthewDKAuthor Commented:
No mailbox databases were referring to the first OAB, so it has been deleted. Do any services need to be restarted prior to attempting to resume the 2013 installation?
0
MatthewDKAuthor Commented:
Deleting the Offline Address Book that was pointing to a deleted public folders database allowed me to continue with the installation.
0
Schnell SolutionsSystems Infrastructure EngineerCommented:
Great
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.