linux and german character

Hi

i have a linux open suse server

i mount NFS on this machine form Solaris host and the directory names look OK for German character for example this word (( Änderung  ))

then i mount NFS share from EMC celerra  and i got one the same host the names  look lie, this  (( ?nderung ))

any advice how can fix this

regards
Sword
LVL 1
sword12Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
I'm guessing you don't have "unicode" enabled on the EMC celerra... You can enable it, but if you already populated the file systems enabling unicode might interrupt the availibility...

Here's more info on enabling unicode
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rindiCommented:
Personally I'd always suggest the good practice to be not to use special characters like umlauts in file-names. For the future teach your users to only use standard characters, and replace "ae" for the umlaut "ä". That makes things more compatible and over all systems.
0
sword12Author Commented:
Hi
in our work environment we have to use German characters  so all application we use and we will use must support unicode

now the question to spravtek  after i enable the unicode on celerra  the current data names will be fixed or i have to migrate the data again ?


thanks
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Zephyr ICTCloud ArchitectCommented:
now the question to spravtek  after i enable the unicode on celerra  the current data names will be fixed or i have to migrate the data again ?

I've never had to enable unicode after the fact, always enable it during setup :-)

But there's apparently a KB article that explains the caveat:
emc143160: "How to enable Unicode support on a Data Mover"

You can enable Unicode support on a Data Mover with existing file systems, using either CLI or the Celerra Manager.

Caveat: If the file systems consist of pure ASCII file and directory names, this will be seamless.  But if file systems have files and directories with characters higher than 128, this can cause problems.  In this case the file system will need to be converted using appropriate code page.  The best practice is to have Unicode enabled prior to file system creation.

If non-ASCII characters are used in filenames or directory names, Contact the EMC Customer Support Center or your EMC Customer Service representative for technical assistance. Please quote the solution ID
 

So if the characters used are in the first 128 characters you should be fine ...
0
sword12Author Commented:
Hi spravtek

i checked celerra configuration and i found the unicode enabled

https://community.emc.com/message/816865

then i create new NFS file system and mounted it and i still cant creat any directory with German character

i will pen case with EMC but if you have any idea please let me know

the funny thing we have old celerra NS-120 and work will but this vnx5300 has this problem

thanks
sword
0
Zephyr ICTCloud ArchitectCommented:
Hmmm not really have an idea except for the conversion, but it should only apply to already created file systems, the procedure is mentioned in this document, page 14 onward.

Definitely check if the folder structure like this exists /nas/site/locale as well as this one /.etc_common/xlt, these contain the translation files.
0
sword12Author Commented:
Hi spravtek

it is look like NFS version problem

on vnx5300 i issued this command

server_nfs server_2 -v4 -service -start

then i mount the fie system without any option so automatically mounted as NFS v4 and the German characters appeared normally  

but when i mount the same NFS as V3  i got the problem  

i don't know on the old celerra ns-120 i mount the fle system as nfs v3 i don't get this problem

the different here   ns-120 has smb version 2     vnx5300 smb vesrion 3

i will keep searching  just to let you know


thanks
sword
1
Zephyr ICTCloud ArchitectCommented:
Interesting, thanks for letting us (me) know, will keep this one in mind :-)
0
sword12Author Commented:
Hi spravtek

finally it work

i changed the translation configuration settings to UTF-8 and it work

http://corpusweb130.emc.com/upd_prod_VNX/UPDFinalPDF/en/International_Character_Sets.pdf
0
Zephyr ICTCloud ArchitectCommented:
Great to hear that sword12!! Thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.