I would like a review of my spanning-tree configuration for a new switch

Hello Experts,

I just received a new switch for our production environment.  I would like to have a second set of eyes go over my configuration to see if I missed anything (with regards to spanning-tree).  Here are my drop configs for vlans, ports and spanning-tree:
! CONFIGURE LOOPBACK
interface loopback0
ip address 10.10.10.22 255.255.255.0
ip mtu 1500
! DISABLING VTP
vtp mode transparent
! CREATE UNUSED-PORTS VLAN
vlan 60
name UNUSED-PORTS
exit
! CONFIGURE 250 VLAN
vlan 250
name MANAGEMENT-VLAN
exit
! CONFIGURE PORTS
interface range gi1/0/1 - 24
shutdown
description UNUSED-PORT
switchport mode access
switchport access vlan 60
spanning-tree portfast
spanning-tree bpduguard enable
exit
interface range gi1/1/1 - 4
shutdown
description UNUSED-PORT
switchport mode access
switchport access vlan 60
spanning-tree portfast
spanning-tree bpduguard enable
exit
! CONFIGURE RAPID-PVST
spanning-tree mode rapid-pvst
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
spanning-tree vlan 250 priority 32768

The priority on my core switch is set to 8192.  With the configuration above, I don't think there is any chance the new switch will become the root bridge.

Thanks for looking.
Nick
LVL 1
ndalmolin_13Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NetExpert Network Solutions Pte LtdTechnical SpecialistCommented:
the config looks perfect, except "spanning-tree vlan 250 priority 32768". Because by default all vlan's on the switch will have 32768 as a STP priority value. you no need to mention specifically
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ndalmolin_13Author Commented:
Thanks for taking the time to review this config.  I appreciate it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switches / Hubs

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.