Domain Trust Fails to "There are currently no logon servers available to service the logon request."

Hi Experts,

I'm currently trying to join two forests together between a Windows 2008 R2 and Windows 2012 R2 domain controller.  The trust being set up is a two-way transitive trust between both forests and domain controllers.  However, at the end of the wizard, it would fail with the following error:

"The operation failed.  There error is: There are currently no logon servers available to service the logon request."

Despite the error, I could see the trust is created on both sides of the domain controllers.  But when trying to validate the trust from the Domain and Trust properties, it would return the following error:

"The outgoing trust was successfully validated.  The secure channel (SC) reset on Active Directory Domain Controller \\TVH-R2D2.tvh.ad of domain tvh.ad to domain tvh2_domain failed with error: There are currently no logon servers available to service the logon request."

Both domain controllers are able to see each other, however, when setting user rights for a folder it could not find any users from the trusted domain.  Currently at a loss on what the issue or cause of the issue is.

Here are some notes and steps that have been tried:
 - Windows 2012 R2 domain controller is at a Windows 2003 forest level and Windows 2008 R2 domain level.
 - Windows 2008 R2 domain controller is at a Windows 2008 R2 forest level and Windows 2008 R2 domain level.
 - Added the trusted domain in the DNS as a secondary zone in the DNS manager with read only access (from both DCs).
 - Added IP address of the trusted domain controller as a DNS forwarder on both servers.
 - Added IP address of each trusted domain controller as a secondary DNS on network adapter of both servers.
 - Both domain controllers can ping each other via hostname and FQDN, and to the domain name itself.
 - There was an previous orphaned domain controller in AD that was used for testing, but have been removed via ADSI Edit.
 - Haven't tried raising forest functional level of the Windows 2012 R2 server from Windows 2003 to Windows 2008 R2 level yet due to concerns of possible conflicts with an Exchange 2003 server in the environment.

Any help or suggestions are appreciated.

Thanks in advanced!

EL
eloredoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

compdigit44Commented:
Have you tried setting up a DNS stub zone on both sides also have you made sure all necessary firewall ports are open to support the AD trust.
0
eloredoAuthor Commented:
I've just tried changing the zone type from secondary to a stub zone on both sides the servers for both domains.  Still a no-go.

I've also tested the following ports (via Telnet method) to make sure they are open on both sides of the servers:

LDAP (389 UDP and TCP)
Microsoft SMB (445 TCP)
Kerberos (88 UDP)
Endpoint resolution — portmapper (135 TCP)

I've noticed when trying to validate from the Windows 2008 R2 domain controller, I would get the following message:

"Information from the primary domain controller (PDC) for the domain tvh2_domain cannot be obtained because: An existing connection was forcibly closed by the remote host.

Make sure that the PDC is operating properly and then try again."

However, from the Windows 2012 R2 server I would receive the "There are currently no logon servers available to service the logon request." message.
0
compdigit44Commented:
What about port 53 TCP/UDP for DNS
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

eloredoAuthor Commented:
Yep.  Port 53 TCP/UDP also looks to be open and listening on both servers.
0
compdigit44Commented:
have you run dcdiag /v /e >c:\dcdiag.txt in both forest?
0
eloredoAuthor Commented:
Issue resolved.  

I was working on the server again and noticed a yellow exclamation point for the network connection icon.  Checked the network adapter IPV4 settings and found both the primary and secondary DNS entries were off by a digit for the IP address.  Corrected it back to the correct IP addresses and is now able to validate the trust on both sides.

A simple overlooked issue leading to an endless troubleshooting.

Thanks again for all of your responses and suggestions!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eloredoAuthor Commented:
Was able to find and correct the issue that was causing the problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Active Directory

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.