Ubuntu 10.04 iPhone issues

I have several HP Smart Zero t410 thin clients at my work place. They're a good replacement for a full desktop machine for many of my users. My question comes in because we have a few users who use their iPhones to take pictures, then upload those pictures to their computers. The reason I'm asking this in the Unix/Linux forum is that these thin clients run Ubuntu 10.04 underneath the hood.

When you plug a thumb drive into a thin clients, it seems to automatically mount and then is somehow passed on to whatever machine the thin client RDPs into. If I could get the iPhone to auto-mount on the thin client, my hope is that it will be passed on like the thumb drives are.

Right now when I ssh into the thin client and get the iPhone plugged in, nothing mounts. When I run the fdisk command, nothing shows up. My question: how can I get the iPhone to auto mount on this Ubuntu install? (FYI, I'm currently RDPing into a Server 2008 terminal server)
travisryanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris HInfrastructure ManagerCommented:
https://help.ubuntu.com/community/PortableDevices/iPhone

Ubuntu 10.04 Lucid Lynx
Lucid natively supports both iPhone and iPod Touch 1G, 2G, 3G, 3GS and 4G models (iPad should also work) running up to firmware 4.0.1 without the need to jailbreak. This is due to GNOME 2.30 libimobiledevice support. For a video demo see this youtube video. For the iPhone4 (iOS 4.1), music syncing does NOT work as libgpod has not implemented this yet. You can view the iPhone filesystem by using ifuse.

If you have a password set up on your device, unlock it first before connecting the USB cable, otherwise Ubuntu will not recognize it.

USB Tethering is not supported out of the box, but you can make it work by following this guide

iPod 5G Nano: After making sure libimobiledevice is installed (and possibly reinstalling it if necessary) you may need to re-install the network-manager package in order to be able to read and write properly.


Try running
sudo apt-get update 

Open in new window


http://www.libimobiledevice.org/
The latest release is 1.2.0

I'm assuming your thin client's libimobiledevice library is ancient.  From what I'm reading, 10.04 should be able to support and auto mount up to the 6+.
0
Chris HInfrastructure ManagerCommented:
You also need to update GVFS >= 1.5.1 and libgpod4 (if you want synch)
0
travisryanAuthor Commented:
Thanks for your help so far, right now I'm stuck on getting the iPhone to be recognized by the thin-client. GVFS by itself didn't seem to see something that could be a considered a volume by itself. I installed ifuse as well to see if that helps.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

travisryanAuthor Commented:
It appears that usbmuxd doesn't currently recognize the device. Is this something you can assist with?
0
Chris HInfrastructure ManagerCommented:
http://unix.stackexchange.com/questions/219560/ubuntu-10-04-iphone-issues

From what I'm gathering, the libmobiledev (since 10.04 is EOL) has not been updated from version .9x

You will not be able to make any phone past an iphone 4s work without some serious linux ninja'ing.  Is there anyway to get a newer version of linux on your thins?

http://h20564.www2.hp.com/hpsc/swd/public/detail?sp4ts.oid=5234196&swItemId=vc_125709_1&swEnvOid=4116#tab5

This looks like the latest core image.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
travisryanAuthor Commented:
The latest core image that you linked is version Z6A44017, we actually have Z6A44019 on our machines. You mentioned "serious linux ninja'ing" and I'm curious what you mean by that.
0
travisryanAuthor Commented:
I feel like we're so close. Here's why: 1) (first attached picture) the iPhone shows on the DMESG screen. 2) (second picture) the iPhone actually shows on the thin client usb manager. 3) When I plug the iPhone directly into the server it does recognize the phone.

So it's almost like something isn't being passed through the thin client to the server to tell it "Hey, this is an iPhone."
iPhone1.JPG
iPhone2.jpg
0
Chris HInfrastructure ManagerCommented:
What version of itunes or iphone driver is on the terminal server?  Have you tried updating it?
0
Chris HInfrastructure ManagerCommented:
Also, the HP screen shot iphone 12a8 indicates it's recognizing an iphone 5.   Do you have an iphone 4 or 4s to test with to see if that gets redirected correctly?
0
travisryanAuthor Commented:
If I plug the phone directly into the server, it detects it. Since that happens it stands to reason I don't need to update the drivers. I'll try to install iTunes but I'm not sure what that would detect if the server can't even recognize the phone as a camera device.
0
travisryanAuthor Commented:
I'll try to dig up a 4 and test that.
0
travisryanAuthor Commented:
installing iTunes didn't help. I found a 4s, that was not recognized.
0
travisryanAuthor Commented:
Choward, if you have anymore suggestions or guidance I would appreciate it.
0
Chris HInfrastructure ManagerCommented:
What rdp client does the image you're on use?
0
travisryanAuthor Commented:
freerdp 1.0.2-hp2.10 is what it says.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.