Remote login to a Windows 8.1 PC no longer works

For the last year we have been using a W8.1 laptop for specific functions by a remote user. We connect to the network through a SonicWall VPN, and then use RDP to login to the PC.

We have been using a local account (no MS account) for all this time without issue. Let's say that local account is "SAM"

Today, we are able to establish the sonicwall connection - but cannot login as SAM. We can connect with another username that IS a MS account i.e. sue@mydomain.com, but not as SAM.

There was a MS KB installed two days ago... I uninstalled it, rebooted, and tried again. No change.

HOWEVER, if I use SAM as the username, and type in the password for one of the MS accounts, I can login... but I am logged in as one of the MS accounts.  Did this twice, because I did not believe it.  Somehow "SAM" got associated with a MS account.

Now the question is can that association be broken.

Suggestions welcome
Tomster2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Can you check the user accounts and PC settings on this machine. It would appear that the machine was changed in PC settings to use a Microsoft account. This would explain what you see.

No updates (including all those to July 22 (or later if you installed them later) changed the local account to an email account.

Did the main user try to update to Windows 10 and back up. Windows 10 enforces email accounts until you change back.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Tomster2Author Commented:
I looked at the PC settings area but I don't see a place where you can tell the machine what type of account to use. Can you give me an idea where to find this setting.  

I did see the accounts in PC settings... SAM is local, the others are MS accounts, but I see no indication of how they could be linked or unlinked.
0
JohnBusiness Consultant (Owner)Commented:
Swipe right, Settings, Change PC Settings, Accounts.

Change one of the accounts to Local and try that.

The Windows Profile for SAM may be damaged and so may need to be recreated.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

Tomster2Author Commented:
First, thank you your replies.  Much appreciated. Here is where things are at.

I deleted the SAM user and the Microsoft Account that became connected to it.

I recreated the SAM user... and can login remotely just fine as that local user.

I can login using other MS accounts that I have added as users.

I added the MS account (email address as login) back in as a user... but am unable to login remotely using that username.
I get a "Your credentials did not work" message.
Checked the password by logging into the account at the MS site. This confirmed I have the right password.
Tried creating a new RDP file both - with and without using microsoftaccount\ before the email address. No change.

Additional info... the remote machine is a standalone PC i.e. no domain, just peer to peer.



You mentioned earlier that " the machine was changed in PC settings to use a Microsoft account".
Not sure what that means. Do you just mean that a MS account was added?

Also, looked at the change password option for the microsoft account - but this is only available if you are logged in as that account... and I can't log in as that account. But that password should be the same as the one used at the microsoft website.

Any other thoughts appreciated.
0
JohnBusiness Consultant (Owner)Commented:
You say you re-created SAM and that worked.  You say email accounts do not work and I think I expected that. Only use Local accounts for remote access. You say that works with SAM.

I can't log in as that [email] account.  <-- I suggest you remove the account and try again if you need it. Otherwise just remove it.

" the machine was changed in PC settings to use a Microsoft account".  <-- I was thinking that someone changed the account on you (and you were not aware).
0
Tomster2Author Commented:
Found out why I couldn't login with the MS account.

I was working remotely over rdp.  I deleted the old MS account. Recreated it.  Could not login with it... and was getting the "your credentials did not work message".

The problem was that when you add a MS account PC to a computer (at least to this computer) it asks you to verify that you ARE you by texting a code to the phone number of record - I am familiar with that from other machines. Unfortunately... remote desktop was not displaying this message. Without the confirmation it was looking for it said "your credential did not work". The message should have been "Sorry, we are not going to show you the option to confirm your credentials".  

While I was working on something else, I thought - "I am not seeing any of the confirmation code stuff"

I then had someone onsite start a login with the MS account... they requested the text, I got the code from the user who was traveling... relayed that to the onsite person... and the login completed. After that, RDP worked fine.

Hope that little sticking point helps someone else out.

Something else that might help, is that when you have a local account and a MS account, you can link those two accounts together (deliberately, or in this case accidentally). Once you do that, the password for the local account login no longer works. You need to use the password for the MS account. You can apply that password when using the MS login name, or the local account login name. Regardless of which one you use, the machine will display the MS account as the logged in account. An unintended linking is what I believe created the issue in the first place.

Thanks for sticking with the thread, John. Appreciate it.
0
Tomster2Author Commented:
The answer is in my August 3 at 16:13.  John's comments were not the answer by themselves... but I appreciate his sticking with me until I stumbled across the cause... and solution.  I am giving him the points.
0
JohnBusiness Consultant (Owner)Commented:
Thanks for the update and I was happy to help.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 8

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.