RAID 1 how to repair

PC win 7 2 HD's in RAID 1...
Was booting but running very slow...

Booting up raid says device 0 said something I didn't write down...but indicating drive was a"faulty" drive...
I booted with Macrium and was successful in creating an Image but took about 3 hours...less than 1 Gb of data...

SATA ports are numbered 1,2,3,4 and I assumed that device 0 was plugged into SATA1...
So I disconnected SATA 2 assuming that would be device 1...mounted it on another PC
and successfully pulled all data off and saved to another HD...seemed very normal operation...

I tried booting off the one drive...supposedly the bad one...POST showed up too many drives to show...

I mounted drive 1 previously removed and attached to another pc and tried to boot up...with both drives
assumed to be back in RAID1 with one bad HD...

Tried to boot up and says "No Boot Device"....
In turn I tried to boot up with one drive, than the other and each time I get No Boot Device

At this point I'm stuck...not sure what to do...
I have what I think is a good image...I could forget about doing a RAID1  put in a new single drive and try the image...see if it works...

Or I could put in a new single drive...do a clean install of Win 7 and move the data over...Probably the best solution...

But can anyone suggest a way that I might be able to replace the one bad HD in the RAID and get things working again...???
LVL 2
Steve MutchlerIT TechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
How was the array setup? did you use Mainboard fake-RAID or Windows builtin RAID?

If it was fake-RAID, I'd not try a fix, as that is a terrible way to have RAID in the first place.

If it was OS built-in RAID, it depends on how it was originally setup. If correctly setup, you would have had the small, probably 100MB boot partition as well as the rest of the disk RAIDed. If the small partition wasn't RAIDed, then the array wasn't setup correctly which could be the reason it won't boot now.

You can try booting the PC using Paragon's rescue kit, and then repair the system:

http://www.paragon-software.com/home/rk-free/

If you can boot to the OS after that, just install the new disk and add it to your array, making surethat you also include the 100MB partition in a RAID 1 array.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Steve MutchlerIT TechAuthor Commented:
I did not set the array up...so I don;t think I can answer your question...

I'll try Paragon and see what happens...if no joy...

I'll just rebuild using a single disk in the normal way...l
Thanks
rindiCommented:
You can then always create a proper software RAID like I mentioned above.
Discover the Answer to Productive IT

Discover app within WatchGuard's Wi-Fi Cloud helps you optimize W-Fi user experience with the most complete set of visibility, troubleshooting, and network health features. Quickly pinpointing network problems will lead to more happy users and most importantly, productive IT.

David Johnson, CD, MVPOwnerCommented:
RAID is different than ACHI or IDE-Compat. How did you create your RAID 1?  Using the RAID controller on the motherboard or from the Operating system?

If you used the fakeraid chip on the motherboard then you have to use it's setup routines.. If you can remember how things were plugged in originally then return the system to the spot it was and unplug drives 1 at a time and reboot until you find the failed drive, now replace the drive and rebuild the array.

For the  nth time.. RAID does not equal backup..
David Johnson, CD, MVPOwnerCommented:
you cannot have RAID for 1 DISK.. Redundant Array of Independent Disks
ARRAY means more than 1
DavidPresidentCommented:
You can have a single-disk RAID1 if you use any of the unix software RAIDs.   This has it's place.  It protects against unreadable blocks which are 100x more likely than a catastrophic failure.  Plus it can still improve read time ...

Still, that doesn't help you..   My guess is that your RAID controller puts metadata starting at physical block #0 of the drive, so logical block #0 of your degraded RAID1 is at physical block #n+0.  Logical block #1 is at n+1, and so on, where n=# of metadata blocks.

Get a binary editor that lets you examine physical blocks (google binary editor windows), and choose one.  Then page down and look for the partition headers.  It might be 64KB or even a few MB, but you'll know it when you see it.  

If you see the partition header at physical block #0, then you know it is NOT a metadata problem.

Then you can boot a system to LINUX and use the dd command to start copying the raw device to another scratch drive, starting from the logical block #0 of your RAID drive to physical block#0 of your replacement drive.  The # of blocks you copy will be the physical capacity of the source disk - # the number of metadata blocks.
Don ThomsonCommented:
You said that you noticed that something flashes during the initial  boot that Device 0 was faulty.  This would normally mean that the drive that is plugged into the 1st SATA port was b ad. This means that the Raid hardware controller sees one of it's members as bad. So it must be using the motherboard hardware Raid - plain and simple - just remove the bad drive and restart. The hardware raid should now see a blank member and should start duplicating the good drive on it's own. The trick is always make sure that the two dives are identical. Depending on what motherboard you have - you may have to create the raid from scratch. Check with the motherboard manual.

With raid 1  - the system will boot from the "good" Drive  but not from the "Bad" one.
Steve MutchlerIT TechAuthor Commented:
Paragon did not work...So I put in 2 NEW hd's...and restored with the image...
Then I realized that I cannot create a mirrored array in Windows using one of the HD's that holds the OS...

So I'm running on 1 HD and things are working fine...
Am setting up a backup program to auto backup to the 2ed drive...

Thanks for the help...
rindiCommented:
You can image the OS inside Windows. First convert your disks to dynamic, and after that you can build your arrays.

If you can't convert to dynamic, you don't have enough unallocated space on the disk. Shrink your last partition by about 10MB (you can do that within disk management), then you can convert it to dynamic.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Hardware

From novice to tech pro — start learning today.