HELO on Exchange Wrong and Some MAil not hitting Receipients Mailbox's

Hi Experts!

Hope everyone is well?

I wonder if somebody could help me on a small issue that is driving me made?

The background in case it helps ... The Group i work for has around 8 companies and they are all running on different hosting platforms and were using the IMAP Mail from them.

We are now moving them all over to Exchange 2013. Currently we have a single Exchange 2013 Server with 14 Domains on. As we have no static IP we are using the services of NO-IP with the SMTP SmartHost and Alterative Mail Services.

Some Mail is not been delivered and some of the remote Admins have said its because our HELO banner on mail.trustgroup-uae.com is wrong (Showing our internal address). Now we are also sending mail from other domains out of this exchange server which is also not hitting all there recipient's. An Example would be trusttravel.ae.

If I send a E-Mail to helocheck@helocheck.abuseat.org i get the following back:-

Diagnostic information for administrators:

Generating server: smtp-auth.no-ip.com

helocheck@helocheck.abuseat.org
 helocheck.abuseat.org
 Remote Server returned '<helocheck.abuseat.org #5.0.0 smtp; 550 *** The HELO for IP address 8.23.224.61 was 'out.smtp-auth.no-ip.com' (valid syntax) ***>'


Original message headers:
Return-Path: <Test@trustgroup-uae.com>
X-No-IP: tsgroup@noip-smtp
X-Report-Spam-To: abuse@no-ip.com
Received: from mail.trustgroup-uae.com (unknown [2.50.140.161])
    (Authenticated sender: tsgroup@noip-smtp)
     by smtp-auth.no-ip.com (Postfix) with ESMTPA id 1BC5A400BEE
       for <helocheck@helocheck.abuseat.org>; Mon,  3 Aug 2015 05:08:31 -0700 (PDT)
Received: from TMES1SR005.trustgroup-uae.local (10.1.1.105) by
 TMES1SR005.trustgroup-uae.local (10.1.1.105) with Microsoft SMTP Server (TLS)
 id 15.0.995.29; Mon, 3 Aug 2015 16:08:27 +0400
Received: from TMES1SR005.trustgroup-uae.local ([10.1.1.105]) by TMES1SR005
 ([10.1.1.105]) with mapi id 15.00.0995.028; Mon, 3 Aug 2015 16:08:27 +0400
From: Test <Test@trustgroup-uae.com>
To: "helocheck@helocheck.abuseat.org" <helocheck@helocheck.abuseat.org>
Subject: FW: t
Thread-Topic: t
Thread-Index: AdDIiMFAGfqJsyJiTW+I961NJ39XxAFXFXrc
Date: Mon, 3 Aug 2015 12:08:27 +0000
Message-ID: <1438603662370.96941@trustgroup-uae.com>
References: <5bc7bba468184963b2da6f5edb6ba566@TMES1SR005>
In-Reply-To: <5bc7bba468184963b2da6f5edb6ba566@TMES1SR005>
Accept-Language: en-GB, en-US
Content-Language: en-GB
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
x-originating-ip: [86.46.187.161]
x-c2processedorg: 82b37dc4-7555-4238-a8ce-01381b117f83
Content-Type: multipart/alternative;
   boundary="_000_143860366237096941trustgroupuaecom_"
MIME-Version: 1.0

So .. Im have a Hub Transport Receive Connector setup within Exchange which is on port 2525 (The one we are using for Alternative Mail SMTP Port from No-IP) but when i try and change the HELO from the local address to the FDQN i get the following error:-

If the AuthMechanism attribute on a Receive connector contains the value ExchangeServer, you must set the FQDN parameter on the Receive connector to one of the following values: the FQDN of the transport server "TMES1SR005.trustgroup-uae.local", the NetBIOS name of the transport server "TMES1SR005", or $null.

I have attached a get-receiveconnector !fl output of all my receive connectors.

I could create a new receive connector just for Internet Mail but cant set it on port 2525 because the original one is already using port 2525.

Could anybody help me here? What do I need to do?

Cheers
Si
Cons.txt
LVL 1
TrustGroup-UAEAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
As you are on a dynamic IP address, the ehlo settings will have no effect on email delivery. You are obviously using a smart host, so it is their setup that needs to be correct, which you have no control over.

The only ehlo setting that can affect email delivery is on the receive connectors. They should be left as default, which will be your internal server name.

The remote admins are seeing your internal server name on the inbound banner, and presuming that is applying to the external as well - which is not the case.

If your email delivery is failing for some reason, it is for another reason.

Simon.
TrustGroup-UAEAuthor Commented:
Hi Simon,

Man y thanks for your reply.  I'm having a right time with this. We have around 20% of domains r ejecting (or never receiving) mail.  I can see it leaving our exchange and the smart host admins (no-ip) are t elling me that it's leaving there's. A couple of the ad,ins on the domains were having problem with are telling me it looks like the spam filter is catching it for some reason.

TrustGroup-UAE.com always sends
Trusttravel.ae is the one where they don't always receive the mail.

Both on the same exchange server and both using the same smart host and account.

I'm running round in circles with it .......

Was hoping someone on here would be able to give some pointers on what and where to check, maybe with DNS setup. Mx records etc.

Cheers
Si
SteveCommented:
To confirm: are you having trouble sending out, not receiving in?

Assuming this is the case, I'd normally recommend checking your send connector and see what FQDN is set. Where possible, make it match the FQDN you use for the incoming MX record and set rDNS up for it on your IP.

As you are on a dynamic IP and use the smarthost you're a bit screwed as this simply isn't possible.
For the moment, turn on SMTP send logging so you can see the actual communication between your server and the smarthost. Once the smarthost accepts your message it's out of your hands and you have to hassle the smarthost providers.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Simon Butler (Sembee)ConsultantCommented:
I think the problem is the domain.
.ae domains are considered suspicious by a lot of locations.
Add that to a commercial smart host service which often gets blacklisted, and you probably have a perfect storm.

There isn't much you can do, other than trying another outbound email service. If you cannot get a static IP address you may well have to start considering a move to the cloud.

Simon.
SteveCommented:
I Agree with Simon. Your setup is just asking for problems so reconsidering is a good idea even if you fix this issue.
Check the SMTP logs to confirm exactly what is happening, but I suspect moving away from this smarthost may be worth considering unless the logs show your system is the issue.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.