Voicemail - changing the default recording path

Hi,

I'm trying to change the asterisk voicemail recording path from its default path:
 
/var/spool/asterisk/voiocemail/

To:
 
/asterisk/voicemail

I have altered the asterisk.conf from:

astspooldir => /home/spool/asterisk
to
astspooldir => /asterisk

Yet the messages are still following the default path.  What am I missing??

Thank you
doddeers668Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joolsCommented:
Did you reload asterisk?
0
doddeers668Author Commented:
Yes, asterisk reloaded. Even restarted the server.
0
joolsCommented:
Have you tried doing a sym link from the original directory to the new one?

eg/

ln -s /var/spool/asterisk/voicemail/ /asterisk/voicemail

Doesnt the spool dir have other stuff in it? (I dont have an asterisk server available to check myself)
1
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

doddeers668Author Commented:
symbolic link isn't really an option.  The directory for the intended voicemail has an increased diskspace, specifically for voicemail messages and will sync with a backup server using lsyncd.

The spool dir will still support other applications, that's why I'm keeping the original as it is in addition to the new spool dir for Asterisk. Is that an issue??

Thanks for getting back.
0
joolsCommented:
not sure why it wont be an option, you could just link the directory where the voice mails are stored to the new location with the increased disk space.

I did have a VM with Asterisk but its not working so cant try it out.
0
doddeers668Author Commented:
Thanks for your help Jools, I've found the solution.

All I had to simply do was delete the (!) from [directories] in asterisk.conf
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
doddeers668Author Commented:
I found the solution and added it to the string for others to see.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.