linux machine login issue

why iam not able to login through console while enter the user name it is not asking for password, please help me out
loginerror1.jpg
hasan koduruAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
- Does the machine have an IP-address? If it does, can you ssh into it?
- Can you login as root, do you get a prompt with root?
- Can you switch virtual console (ctrl-alt-F2) and check there?

- If all else fails you might have to reboot into single mode and check for issues.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hasan koduruAuthor Commented:
Yes we tried with SSH with IP address of the machine, it prompts user name and after entering password it is not responding and finally automatically closing SSH. (using root user credentials). we went single user mode, please help how to check errors.
0
Zephyr ICTCloud ArchitectCommented:
You already accepted a solution, but ok :)

First check the ssh file with

cat /etc/ssh/sshd_config

Open in new window


Check if this line "PasswordAuthentication" is set to yes:
PasswordAuthentication yes

Open in new window


Also check the logs, eg. /var/log/syslog or /var/log/messages for errors.
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

hasan koduruAuthor Commented:
please find attached screen shot of /var/log/messeges. and help me out how to notify the error
messeges-log.jpg
messeges-log2.jpg
0
Zephyr ICTCloud ArchitectCommented:
Sorry, those logs don't help pinpoint the login issue ... Did  you check the sshd_config file?

do following if you want to change something:

vi /etc/ssh/sshd_config

Open in new window


press "i" for making changes.
When done, press "esc" and type "wq" followed by enter.

Did you try the other suggestions?
0
hasan koduruAuthor Commented:
yes, i tried which you suggested all, then forwarded log files, do the needful help for loging
0
Zephyr ICTCloud ArchitectCommented:
Well, if you're still in single mode check a few things like diskspace for example.

df -h

Open in new window


permissions on /etc/shadow

ls -la /etc/shadow

Open in new window


The logs didn't give any helpful info.
0
hasan koduruAuthor Commented:
i hope this attached log can help out. please check and do the help
messeges-log3.jpg
0
hasan koduruAuthor Commented:
Please find attached df -h and ls -la /etc/shadow file file
messeges-log4.jpg
0
Zephyr ICTCloud ArchitectCommented:
I see a few issues that might explain this:

1- You seem to have LDAP authentication enabled
2- SSH is listening on 0.0.0.0, which indicates no network is set or started.

This combination will most likely cause the problem you're having.

In single user mode check /etc/sysconfig/network-scripts/ifcfg-eth0 (<--- replace eth0 with the name of your nic).
0
hasan koduruAuthor Commented:
than help me how to resolve this issue
0
Zephyr ICTCloud ArchitectCommented:
In single user mode check /etc/sysconfig/network-scripts/ifcfg-eth0 (<--- replace eth0 with the name of your nic).

Begin with what I requested above ... We need to check the settings of the network.


More info
0
hasan koduruAuthor Commented:
Please find attached /etc/sysconfig/network-scripts/ifcfg-eth0 report
messeges-log5.jpg
0
Zephyr ICTCloud ArchitectCommented:
Try this command:

authconfig --disableldapauth --disableldap --enableshadow

Open in new window


Execute it in single mode and reboot if it was succesfully executed.
0
hasan koduruAuthor Commented:
yeah i got it with authconfig --disableldapauth --disableldap --enableshadow --updateall

thank you very much for all your support.


Regards,
Hasan K
0
Zephyr ICTCloud ArchitectCommented:
Great, no problem
0
ashraf hussainCommented:
now the same having problem to communicating with DNS, please find below error messege

Aug 19 03:39:00 ncptmaxqa ntpdate[29027]: can't find host 1.rhel.pool.ntp.org
Aug 19 03:39:40 ncptmaxqa ntpdate[29027]: can't find host 2.rhel.pool.ntp.org
Aug 19 03:39:44 ncptmaxqa ntpdate[29027]: no server suitable for synchronization found
Aug 19 03:39:44 ncptmaxqa ntpd[29151]: ntpd 4.2.2p1@1.1570-o Mon May 30 15:43:16 UTC 2011 (1)
Aug 19 03:39:44 ncptmaxqa ntpd[29152]: precision = 1.000 usec
Aug 19 03:39:44 ncptmaxqa ntpd[29152]: Listening on interface wildcard, 0.0.0.0#123 Disabled
Aug 19 03:39:44 ncptmaxqa ntpd[29152]: Listening on interface lo, 127.0.0.1#123 Enabled
Aug 19 03:39:44 ncptmaxqa ntpd[29152]: Listening on interface eth0, 192.168.7.232#123 Enabled
Aug 19 03:39:44 ncptmaxqa ntpd[29152]: kernel time sync status 0040
Aug 19 03:39:44 ncptmaxqa ntpd[29152]: getaddrinfo: "::1" invalid host address, ignored
Aug 19 03:41:44 ncptmaxqa ntpd[29152]: frequency initialized 46.235 PPM from /var/lib/ntp/drift
Aug 19 03:42:24 ncptmaxqa ntpd[29152]: getaddrinfo: "0.rhel.pool.ntp.org" invalid host address, ignored
Aug 19 03:43:04 ncptmaxqa ntpd[29152]: getaddrinfo: "1.rhel.pool.ntp.org" invalid host address, ignored
Aug 19 06:15:40 ncptmaxqa ntpd[29152]: getaddrinfo: "2.rhel.pool.ntp.org" invalid host address, ignored
Aug 19 06:16:22 ncptmaxqa ntpd_initres[29354]: host name not found: 0.rhel.pool.ntp.org
Aug 19 06:16:22 ncptmaxqa ntpd_initres[29354]: couldn't resolve `0.rhel.pool.ntp.org', giving up on it
Aug 19 06:17:02 ncptmaxqa ntpd_initres[29354]: host name not found: 1.rhel.pool.ntp.org
Aug 19 06:17:02 ncptmaxqa ntpd_initres[29354]: couldn't resolve `1.rhel.pool.ntp.org', giving up on it
Aug 19 06:17:42 ncptmaxqa ntpd_initres[29354]: host name not found: 2.rhel.pool.ntp.org
Aug 19 06:17:42 ncptmaxqa ntpd_initres[29354]: couldn't resolve `2.rhel.pool.ntp.org', giving up on it
Aug 19 06:18:52 ncptmaxqa ntpd[29152]: synchronized to LOCAL(0), stratum 10
Aug 19 06:18:52 ncptmaxqa ntpd[29152]: kernel time sync disabled 0001
Aug 19 07:01:38 ncptmaxqa avahi-daemon[3913]: Withdrawing address record for 192.168.7.232 on eth0.
Aug 19 07:01:38 ncptmaxqa avahi-daemon[3913]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.7.232.
Aug 19 07:01:38 ncptmaxqa avahi-daemon[3913]: iface.c: interface_mdns_mcast_join() called but no local address available.
Aug 19 07:01:38 ncptmaxqa avahi-daemon[3913]: Interface eth0.IPv4 no longer relevant for mDNS.
Aug 19 07:01:38 ncptmaxqa kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Aug 19 07:01:38 ncptmaxqa kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Aug 19 07:01:39 ncptmaxqa avahi-daemon[3913]: New relevant interface eth0.IPv4 for mDNS.
Aug 19 07:01:39 ncptmaxqa avahi-daemon[3913]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.7.232.
Aug 19 07:01:39 ncptmaxqa avahi-daemon[3913]: Registering new address record for 192.168.7.232 on eth0.
Aug 20 03:34:44 ncptmaxqa avahi-daemon[3913]: Withdrawing address record for 192.168.7.232 on eth0.
Aug 20 03:34:44 ncptmaxqa avahi-daemon[3913]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.7.232.
Aug 20 03:34:44 ncptmaxqa avahi-daemon[3913]: iface.c: interface_mdns_mcast_join() called but no local address available.
Aug 20 03:34:44 ncptmaxqa avahi-daemon[3913]: Interface eth0.IPv4 no longer relevant for mDNS.
Aug 20 03:34:45 ncptmaxqa kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Aug 20 03:34:45 ncptmaxqa kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Aug 20 03:34:49 ncptmaxqa avahi-daemon[3913]: New relevant interface eth0.IPv4 for mDNS.
Aug 20 03:34:49 ncptmaxqa avahi-daemon[3913]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.7.232.
Aug 20 03:34:49 ncptmaxqa avahi-daemon[3913]: Registering new address record for 192.168.7.232 on eth0.
Aug 20 03:45:22 ncptmaxqa avahi-daemon[3913]: Withdrawing address record for 192.168.7.232 on eth0.
Aug 20 03:45:22 ncptmaxqa avahi-daemon[3913]: Leaving mDNS multicast group on interface eth0.IPv4 with address 192.168.7.232.
Aug 20 03:45:22 ncptmaxqa avahi-daemon[3913]: iface.c: interface_mdns_mcast_join() called but no local address available.
Aug 20 03:45:22 ncptmaxqa avahi-daemon[3913]: Interface eth0.IPv4 no longer relevant for mDNS.
Aug 20 03:45:23 ncptmaxqa kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: None
Aug 20 03:45:23 ncptmaxqa kernel: 8021q: adding VLAN 0 to HW filter on device eth0
Aug 20 03:45:24 ncptmaxqa avahi-daemon[3913]: New relevant interface eth0.IPv4 for mDNS.
Aug 20 03:45:24 ncptmaxqa avahi-daemon[3913]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.7.232.
Aug 20 03:45:24 ncptmaxqa avahi-daemon[3913]: Registering new address record for 192.168.7.232 on eth0.
Aug 20 05:14:03 ncptmaxqa ntpdate[15407]: can't find host 0.rhel.pool.ntp.org


Regards,
Hasan K
0
ashraf hussainCommented:
Please find belowerror

[root@ncptmaxqa ~]# /sbin/ntpdate -u 192.168.15.250
20 Aug 05:18:13 ntpdate[15652]: no server suitable for synchronization found
[root@ncptmaxqa ~]# nmap 192.168.15.250

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2015-08-20 05:30 EDT
Note: Host seems down. If it is really up, but blocking our ping probes, try -P0
Nmap finished: 1 IP address (0 hosts up) scanned in 2.065 seconds
[root@ncptmaxqa ~]# nslookup 192.168.15.250
;; connection timed out; no servers could be reached

[root@ncptmaxqa ~]# nslookup 192.168.15.250
;; connection timed out; no servers could be reached

[root@ncptmaxqa ~]# cat /etc/resolv.conf
search ksoftglobal.com
nameserver 192.168.15.250
nameserver 8.8.8.8
[root@ncptmaxqa ~]#
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.