Does not support TLS, would this cause any problem?

This is using MS SBS 2011 server. Exchange 2010 also running on this server. However, few users told me that they seem to have not receiving some expected mails, and they request me to check through the exchange. I did a thorough check, look like everything is working fine except for the smtp test from MXToolbox with the 2 warnings as attached.

Does the not supporting TLS matter? Shall I change so as it support TLS and so how?

thanks,
LVL 1
MichaelBalackAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott CSenior EngineerCommented:
The warnings didn't get attached.  

However, here is how to enable TLS.

http://tecadmin.net/enable-tls-on-windows-server-and-iis/

Step 1: Backup Registry Values

We strongly recommend to take a backup of registry before making any changes. Use below link to find steps to how to export registry values.

http://windows.microsoft.com/en-in/windows/back-up-registry

Step 2: Enable TLS 1.1 and TLS 1.2

2.1 Open registry on your server by running ‘regedit‘ in run window and navigate to below location.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols


2.2 Add the TLS 1.1 and TLS 1.2 keys under Protocols. It will looks like directories.

TLS-1

2.3 Now create two keys Client and Server under both TLS keys.

2.4 Now create the DWORD Values under Server and Client key as following
  DisabledByDefault [Value = 0]
  Enabled [Value = 1]


TLS-2

Step 3: Disable SSLv3 and Older Version

3.1 Open registry on your server by running ‘regedit’ in run window and navigate to below location.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols


3.2 Now change DWORD Values under Server and Client under SSLv3 and Older SSL version keys.
  DisabledByDefault [Value = 0]
  Enabled  [Value = 0]


After making all above setting reboot your server.
MichaelBalackAuthor Commented:
Hi ScottCha,

Please see the attachment.
EE---MXTool-Errors.jpg
Scott CSenior EngineerCommented:
Thanks.  I see it now.  Try enabling TLS and see if that clears up the message.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MichaelBalackAuthor Commented:
Thanks for Scottcha's suggestion, Now, my Exhange server is support TLS.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.