windows 10 favorite links how to stop security popup

I just upgraded to Windows 10 from Windows 7.  I have a folder from Win 7 on my taskbar to open links at C:\Users\Jane\Favorites\Links\Reference. I had them working fine with Win 7 but now with Win 10, I get the popup below each time I click on them. Anyone know how to stop the popup?  Thx.
security popup
LVL 39
thenelsonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joshua GrantomSenior Systems AdministratorCommented:
I would open up a command prompt and run the following line by line. this will change the Integrity Level of the shortcuts to medium instead of low. This should prevent it from prompting you with a security warning every time.

cd C:\Users\Jane\Favorites\Links\Reference
icacls *.lnk /L /SetIntegrityLevel med

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zac HarrisSystems Administrator Commented:
This will most likely get rid of the prompt,

Internet Options > Security > Custom Level > "Launching applications and unsafe files (not secure)" > Enable

However, since this is linked to Windows Integrity levels you can also use this command from an elevated command prompt:

ICACLS "%programdata%\Microsoft\Windows\Start Menu\Programs" /Setintegritylevel (OI)(CI)Medium
0
thenelsonAuthor Commented:
That did it. Thanks!
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Joshua GrantomSenior Systems AdministratorCommented:
glad to help
0
McKnifeCommented:
Joshua, do you have any background info on this? Why would it happen after an OS upgrade?
As I could read, this command is used on win7/8.x too for the same purpose, so this "nagging" should not be something introduced by win10.
0
Joshua GrantomSenior Systems AdministratorCommented:
Its just a theory but I believe that perhaps the OS upgrade

1. Does not preserve the zone assignment for the shortcuts files
or
2. After the upgrade it is considering the folder a redirected folder.

Either one of these would cause a security prompt. I'm curious about this as well.
0
McKnifeCommented:
Thanks. I believe I already saw this on upgraded machines, too, and wanted to look into this later on.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.