Remote desktop from home (with dual monitors) to an office computer under sbs2003

My office has a Windows 7 pro computer named "MaryDoeCEO" which is attached to an sbs2003 server named "Server01".  (Yes, I already know sbs2003 is unsupported, but the boss likes it.)

Mary wants to access her office computer from home.  MaryHome and MaryDoeCEO both have desktops extended over dual 1440 x 900 monitors. Both have windows 7 pro.

When MaryHome connects using RWW, a virtual window into MaryDoeCEO appears on MaryHome monitor, but RWW only allows a few resolutions and none matches my desire which is 2880 by 900 which is wide enough to show both of the MaryDoeCEO screens,

If I use the following MSTSC command from JohnSmithAgent at the office, I get EXACTLY what I want.

mstsc /v:MaryDoeCEO /w:2800 /h:900

But, I cannot figure out how to do the same thing at home.

The solution does NOT have to use Remote Web Workplace. I have read that it is possible to skip RWW and use Remote Desktop through the firewall, but I worry about security issues.  Plus it appears I would need to buy an SSL Certificate which seems fairly complicated. Nonetheless, I would be willing to try that solution if someone can point me to DETAILED instructions.  

I have already done a fair amount of research using Google, and reviewed about 50 pages of suggestions. I am still stumped.  So please, don't respond to this question unless you have great confidence that you know how to solve the problem. For instance, don't just say "try gotomypc".
LVL 5
rberkeConsultantAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bbaoIT ConsultantCommented:
if MSTSC or RDP does the job as you expect, i think the only way here is to use VPN, or specifically do MSTSC or RDP over a VPN connection from your CEO's home to the office.

a well-designed VPN solution is actually more secured than RWW due to less attack surface.
0
Lionel MMSmall Business IT ConsultantCommented:
I agree with the VPN idea but if you want to use mstsc /v:MaryDoeCEO /w:2800 /h:900 then you need to change the /v:MaryDoeCEO to your internet connected IP address for your router and a port to forward it to MaryDoeCEO such as
mstsc /v:49.196.237.118:33182 /w:2800 /h:900
where 49.196.237.118 is the static IP you have on your router which you got from your ISP and 33182 is the port your setup on your router to forward to the MaryDoeCEO Windows 7 PC.

You can test of a VPN by using one of many that offer a trial -- this one has been recommended to me by several experts here on EE https://secure.logmein.com/products/hamachi/
0
bbaoIT ConsultantCommented:
> you need to change the /v:MaryDoeCEO to your internet connected IP address

i don't think so.

once the VPN has been established, the IP address to be used for addressing the remote Windows computer should be an INTERNAL address, the same IP address assigned to the CEO's desktop PC, not an "internet connected IP address".
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

SteveCommented:
so, two things:
a) solve your issue
b) look at other options

Solve the issue:
try 'full screen' when connecting and the resolution of the monitors of your home PC will be matched by the RDP connection. The resolution options are a little limited in RDP so its not a surprise the resolution you want is not listed.
Note: this will need to select 'Use all my monitors for the remote session' to enable dual screen mode.

Look at other options:
direct RDP externally is easy but you are correct that it isn't the most secure of options. You could connect a VPN before connecting but this may be a bit more messing around than you're looking for.
Let's try to fix it first and look at those options if necessary,
0
rberkeConsultantAuthor Commented:
Thanks !!  the missing piece was staring me in right the face.  I simply had to start VPN first which only takes 10 seconds.   (Luckily the server and its router and MaryHome were already configured for VPN.)

Now, I can connect fairly well with mstsc /v:MaryDoeCEO /w:2880 /h:900  (please note bbao is correct, I could have used the INTERNAL IP address assigned by DHCP, but using the actual computer name is obviously better).

But, I now discover things are not as nice as I would like. When I connect from home to the office virtual 2880 x 900 desktop and drag the edges, I can get my two home monitors to look like this  (the green desktop is on the home computer, the black desktop is the office computer):image
I cannot get the office desktop to entirely fill my entire MaryHome monitors.  Even worse, the maximizing the MaryDoeCEO Outlook session causes the fill the entire 2880 x 900 virtual desktop spanned across both home monitors. I would prefer it to maximize to single monitor.  I have a feeling both problems are due to SBS2003 server, so we may be stuck with the problem.  But I am hoping one of the experts can solve these problems.

By the way, I already have rdp configured to use both monitors.
0
rberkeConsultantAuthor Commented:
I didn't realize that the  monitors at home did not have same resolution as the office monitors,  

mstsc /v:MaryDoeCEO /w:3840 /h:2160      then I click on the Maximize button (or alt space x). The virtual monitor completely fills both of the home monitors in a "Full Double Screen" mode.  

And, the "Excel/Outlook Maximize Problem" is also nearly fixed.  Instead of using the Excel Window's maximize button, I use Window Key Right Arrow once or twice and the Excel window fits the righthand monitor perfectly.

Now, one last question.  
Does anybody know how to get the /multimon to work?  In my testing it does not seem to do anything. I tried using it instead of /w and /h, but it gave me a black screen.  And /multimon was ignored when used with the /w and /h switch.

Does anybody know how to make rdp open in "Full Double Screen" mode to avoid keying the <alt space x>
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.