set global group_concat_max_len

Hi Experts,

This is related to another question that I recently closed, but I am trying to check my syntax for set global group_concat_max_len , but I am getting the following output. What am I doing wrong?

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysqld --group_concat_max_len = 4294967295;
Unknown suffix '=' used for variable 'group_concat_max_len' (value '=')
2015-08-05 16:13:21 0 [Warning] option 'group_concat_max_len': unsigned value 0 adjusted to 4
2015-08-05 16:13:21 0 [ERROR] mysqld: Error while setting value '=' to 'group_concat_max_len'
2015-08-05 16:13:21 0 [ERROR] Aborting

2015-08-05 16:13:21 0 [Note] Binlog end


C:\Program Files\MySQL\MySQL Server 5.6\bin>mysqld set global group_concat_max_len = 4294967295;
2015-08-05 16:13:54 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-08-05 16:13:54 7400 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test
2015-08-05 16:13:54 7400 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test

Open in new window

APD TorontoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve BinkCommented:
For your first example, the '=' sign is unnecessary.  The correct command would be:
mysqld --group_concat_max_len 4294967295

Open in new window


A better option would be to put the value in your my.cnf.

For your second example, you would need the -e switch, and you would run this from the mysql client, not the mysqld server.  Example:
C:\Users>mysql -e "show variables like '%group%concat%';"
+----------------------+-------+
| Variable_name        | Value |
+----------------------+-------+
| group_concat_max_len | 1024  |
+----------------------+-------+

C:\Users>mysql -e "set global group_concat_max_len=4;"

C:\Users>mysql -e "show variables like '%group%concat%';"
+----------------------+-------+
| Variable_name        | Value |
+----------------------+-------+
| group_concat_max_len | 4     |
+----------------------+-------+

C:\Users>mysql -e "set global group_concat_max_len=1024;"

C:\Users>mysql -e "show variables like '%group%concat%';"
+----------------------+-------+
| Variable_name        | Value |
+----------------------+-------+
| group_concat_max_len | 1024  |
+----------------------+-------+

Open in new window

0
APD TorontoAuthor Commented:
Before I place this in my.cnf (my.ini in my case) I am using mysqld to test the syntax, but I am still not getting it to work.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\System32>cd C:\Program Files\MySQL\MySQL Server 5.6\bin

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysqld --group_concat_max_len 4294967295
2015-08-06 11:17:00 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-08-06 11:17:00 8792 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test
2015-08-06 11:17:00 8792 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test

C:\Program Files\MySQL\MySQL Server 5.6\bin>

Open in new window


After this I am checking in phpMyAdmin my variables and it still 1024.
0
Steve BinkCommented:
You'll need to look in the log file to see what happened.  Per your paste, your MySQL server is stopping immediately after you start it.  The log will have more information on why.  For example, I open two command windows.  In Window 1 (note that I'm shutting down the installed service first):
C:\bb\mysql\bin>net stop MySQL
The MySQL service is stopping.
The MySQL service was stopped successfully.


C:\bb\mysql\bin>mysqld --standalone
2015-08-06 11:52:10 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp
server option (see documentation for more details).

Open in new window

Then in Window 2:
C:\Users>mysql -u root -p
Enter password: ****
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.6.20-log MySQL Community Server (GPL)

Copyright (c) 2000, 2014, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show variables like '%group%';
+----------------------------+-------+
| Variable_name              | Value |
+----------------------------+-------+
| group_concat_max_len       | 1024  |
| innodb_log_files_in_group  | 2     |
| innodb_log_group_home_dir  | .\    |
| innodb_mirrored_log_groups | 1     |
| slave_checkpoint_group     | 512   |
+----------------------------+-------+
5 rows in set (0.00 sec)

mysql> exit
Bye

C:\Users>mysqladmin -u root -p shutdown
Enter password: ****

C:\Users>

Open in new window

Once I have run the `mysqladmin shutdown` command, window 1 returns to the prompt.  Then, in Window 1:
C:\bb\mysql\bin>mysqld --group_concat_max_len 4294967295
2015-08-06 11:54:54 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp
server option (see documentation for more details).

Open in new window

And in Window 2:
C:\Users>mysql -u root -p
Enter password: ****
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 1
Server version: 5.6.20-log MySQL Community Server (GPL)

Copyright (c) 2000, 2014, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show variables like '%group%';
+----------------------------+------------+
| Variable_name              | Value      |
+----------------------------+------------+
| group_concat_max_len       | 4294967295 |
| innodb_log_files_in_group  | 2          |
| innodb_log_group_home_dir  | .\         |
| innodb_mirrored_log_groups | 1          |
| slave_checkpoint_group     | 512        |
+----------------------------+------------+
5 rows in set (0.00 sec)

mysql> exit
Bye

C:\Users>mysqladmin -u root -p shutdown
Enter password: ****

C:\Users>

Open in new window

Again, once I execute the shutdown, window 1 returns to the prompt.

I have no idea if your phpMyAdmin installation is properly connected to your local MySQL service - that is an entirely separate issue.  I recommend implementing and verifying this setup through the command line utilities before trying to work with phpMyAdmin.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

APD TorontoAuthor Commented:
HMMM, Something wierd is happening.

I agree with you, let's leave phpMyAdmin out of this.

Below I am pasting WIndow 1, Window2, and the log entries for the affected time period.

First issue I see that net stop does not find mysql, but I can see it running in my services window.

Secondly, by your reply I assume that mysqld --group_concat_max_len 4294967295 is supposed to restart the mysql server, but you will see in my second window it does not.

The log file does not seem to contain any useful information (at least by what I can see)

Window 1
C:\Program Files\MySQL\MySQL Server 5.6\bin>net stop mysql
The MySQL service is not started.

More help is available by typing NET HELPMSG 3521.


C:\Program Files\MySQL\MySQL Server 5.6\bin>mysqld --standalone
2015-08-06 12:10:43 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-08-06 12:10:43 7652 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test
2015-08-06 12:10:43 7652 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysqld --group_concat_max_len 4294967295
2015-08-06 12:16:34 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2015-08-06 12:16:34 5184 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test
2015-08-06 12:16:34 5184 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Server 5.6\data\OPTIPLEX.lower-test

C:\Program Files\MySQL\MySQL Server 5.6\bin

Open in new window


Window 2
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Windows\System32>mysql -u root -p
'mysql' is not recognized as an internal or external command,
operable program or batch file.

C:\Windows\System32>cd C:\Program Files\MySQL\MySQL Server 5.6\bin

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysql -u root -p
Enter password: ****
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysql -u root -p
Enter password: *****
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 6
Server version: 5.6.23-log MySQL Community Server (GPL)

Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> show variables like '%group%';
+----------------------------+-------+
| Variable_name              | Value |
+----------------------------+-------+
| group_concat_max_len       | 1024  |
| innodb_log_files_in_group  | 2     |
| innodb_log_group_home_dir  | .\    |
| innodb_mirrored_log_groups | 1     |
| slave_checkpoint_group     | 512   |
+----------------------------+-------+
5 rows in set (0.00 sec)

mysql> exit;
Bye

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysqladmin -u root -p shutdown
Enter password: *****

C:\Program Files\MySQL\MySQL Server 5.6\bin>mysql -u root -p
Enter password: *****
ERROR 2003 (HY000): Can't connect to MySQL server on 'localhost' (10061)

C:\Program Files\MySQL\MySQL Server 5.6\bin>

Open in new window


Log File for today
2015-08-06 10:50:37 2748 [Note] Plugin 'FEDERATED' is disabled.
2015-08-06 10:50:37 c04 InnoDB: Warning: Using innodb_additional_mem_pool_size is DEPRECATED. This option may be removed in future releases, together with the option innodb_use_sys_malloc and with the InnoDB's internal memory allocator.
2015-08-06 10:50:37 2748 [Note] InnoDB: Using atomics to ref count buffer pool pages
2015-08-06 10:50:37 2748 [Note] InnoDB: The InnoDB memory heap is disabled
2015-08-06 10:50:37 2748 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2015-08-06 10:50:37 2748 [Note] InnoDB: Memory barrier is not used
2015-08-06 10:50:37 2748 [Note] InnoDB: Compressed tables use zlib 1.2.3
2015-08-06 10:50:37 2748 [Note] InnoDB: Not using CPU crc32 instructions
2015-08-06 10:50:37 2748 [Note] InnoDB: Initializing buffer pool, size = 274.0M
2015-08-06 10:50:37 2748 [Note] InnoDB: Completed initialization of buffer pool
2015-08-06 10:50:38 2748 [Note] InnoDB: Highest supported file format is Barracuda.
2015-08-06 10:50:53 2748 [Note] InnoDB: 128 rollback segment(s) are active.
2015-08-06 10:50:54 2748 [Note] InnoDB: Waiting for purge to start
2015-08-06 10:50:54 2748 [Note] InnoDB: 5.6.23 started; log sequence number 25008084
2015-08-06 10:50:54 2748 [Note] Server hostname (bind-address): '*'; port: 3306
2015-08-06 10:50:54 2748 [Note] IPv6 is available.
2015-08-06 10:50:54 2748 [Note]   - '::' resolves to '::';
2015-08-06 10:50:54 2748 [Note] Server socket created on IP: '::'.
2015-08-06 10:51:02 2748 [Note] Event Scheduler: Loaded 0 events
2015-08-06 10:51:02 2748 [Note] C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld.exe: ready for connections.
Version: '5.6.23-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
2015-08-06 12:16:01 2748 [Note] C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld.exe: Normal shutdown

2015-08-06 12:16:01 2748 [Note] Giving 0 client threads a chance to die gracefully
2015-08-06 12:16:01 2748 [Note] Event Scheduler: Purging the queue. 0 events
2015-08-06 12:16:01 2748 [Note] Shutting down slave threads
2015-08-06 12:16:01 2748 [Note] Forcefully disconnecting 0 remaining clients
2015-08-06 12:16:01 2748 [Note] Binlog end
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'partition'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'PERFORMANCE_SCHEMA'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_DATAFILES'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_TABLESPACES'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN_COLS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_FOREIGN'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_FIELDS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_COLUMNS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_INDEXES'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_TABLESTATS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_SYS_TABLES'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_FT_INDEX_TABLE'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_FT_INDEX_CACHE'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_FT_CONFIG'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_FT_BEING_DELETED'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_FT_DELETED'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_FT_DEFAULT_STOPWORD'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_METRICS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_BUFFER_POOL_STATS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE_LRU'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_BUFFER_PAGE'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX_RESET'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_CMP_PER_INDEX'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_CMPMEM_RESET'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_CMPMEM'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_CMP_RESET'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_CMP'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_LOCK_WAITS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_LOCKS'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'INNODB_TRX'
2015-08-06 12:16:01 2748 [Note] Shutting down plugin 'InnoDB'
2015-08-06 12:16:01 2748 [Note] InnoDB: FTS optimize thread exiting.
2015-08-06 12:16:01 2748 [Note] InnoDB: Starting shutdown...
2015-08-06 12:16:02 2748 [Note] InnoDB: Shutdown completed; log sequence number 25008094
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'BLACKHOLE'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'ARCHIVE'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'MRG_MYISAM'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'MyISAM'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'MEMORY'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'CSV'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'sha256_password'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'mysql_old_password'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'mysql_native_password'
2015-08-06 12:16:02 2748 [Note] Shutting down plugin 'binlog'
2015-08-06 12:16:02 2748 [Note] C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld.exe: Shutdown complete

Open in new window

0
Steve BinkCommented:
It sounds like you might have two separate MySQL installations available on that system.  Take a look in your Services control panel to see where the MySQL service actually points.  Compare that with the location of your actual current server.

>>> Secondly, by your reply I assume that mysqld --group_concat_max_len
>>> 4294967295 is supposed to restart the mysql server,

Sort of...it's supposed to *start* the server, not stop then start (i.e., restart).  If you already have MySQL running, executing mysqld again could have one of a few different results, depending on some configuration items.  For example, a second load on my server fails because it can't open ibdata1 as read/write.  However, those errors and the failure to load is visible in the MySQL log.  Generally, you should be able to see the startup attempt in the log.
0
APD TorontoAuthor Commented:
It is not my intention to have multiple of MySQL Servers running, and I hope that I am not.

Under services I have MySQL and MySQL56. Both point to the same path, MySQL by default is "automatic" and MySQL by default is "Started"

Under Control Panel > programs, I have:
MySQL installer - community
MySQL server 5.6
MySQL workbench 6.2CE

By this, can you tell if I have multiple of mySQL servers running, if so how can I remove? If you cannot tell, then how can I find out?

If you can tell, and I have only 1 MySQL server then what should I do next?
0
APD TorontoAuthor Commented:
Do you see any startup issues in my log? Or is there another log?
0
Steve BinkCommented:
How many entries of mysqld do you show running in your task manager?  Does starting/stopping the server affect that list as you would expect?
0
APD TorontoAuthor Commented:
My task manager services tab resembles my services window in control panel. That is I also have in my task manager MySQL(stopped) and MySQL56(running).

When I stop/start MySQL56 from services, I see this in my task manager.

FYI, I cannot install "MySQL" (different instance from MySQL56.). Do I need the MySQL instance?

I am tempted to dump all of my databases, remove MySQL and re-install. Do you think this will help?
0
Steve BinkCommented:
In your task manager, look at the "Processes" tab.  How many copies of mysqld do you see running?  How are those processes affected by starting and stopping MySQL?

I believe the service being loaded by Windows, and the service you are starting from command line, may be two different copies.  Un-/re-installing may help, but you have to be sure to remove all copies from the system before installing it again.  Otherwise, this issue will reoccur.

Some other things you can try:

1) Run the following command when the service is running.  Is the output what you expect?
mysql -u username -p -e "SHOW DATABASES;"

Open in new window


2) The docs maintain that an equal sign is necessary when using long form options.  Another page in the docs maintains the equal sign is optional.  In my tests, the command without the equal sign worked.  Experiment with that syntax when starting the service.

3) Try putting the option in your my.ini or my.cnf file.  Does that have the desired effect?
0
APD TorontoAuthor Commented:
In your task manager, look at the "Processes" tab.  How many copies of mysqld do you see running?

None, but when I login to mysql -u root -p I get 1 instance of mysql, and it dissapears when I quit. But no instances of mysqld in processes. Is this normal?

Un-/re-installing may help, but you have to be sure to remove all copies from the system before installing it again.  Otherwise, this issue will reoccur.

How can I tell how many copies I have and where they are located?

As well, SHOW DATABASES; from the command prompt does give me what I expect.
0
APD TorontoAuthor Commented:
I noticed that I had a MySQL folder in both C:\Program Files\ and C:\Program Files (x86)\, so I figured that I have 2 instances.

I tried removing the older (x86) using the Windows installer from that directory, but it removed both directories.  Okay, fine, but before installing a fresh copy I checked my services and MySQL (not mysql56) is still there. This service points to the x86 directory, which does not exist anymore, and I could never start this particular instance.

So I guess my question is How can I remove this instance from my services, or if I cant, will I run into the same issue when I install?

Thank you
0
Steve BinkCommented:
>>> None, but when I login to mysql -u root -p I get 1 instance of mysql, and
>>> it dissapears when I quit. But no instances of mysqld in processes. Is this normal?

That's not only not normal, I would say it is impossible if you are connecting to a service on the local system.  On the processes tab, make sure you are looking at processes from all users.  The mysql process is the client, and should exhibit the same behavior you described.  The mysqld process must necessarily exist if you are able to connect to it.

>>> How can I tell how many copies I have and where they are located?

This is normally something you just know as a system administrator.  "Where is X?"  "I installed X here and here."  If you're not sure, you can try search for files/directories with mysql in the name.  Otherwise, it's a hunt.
0
Steve BinkCommented:
See here for removing a Windows service.
0
APD TorontoAuthor Commented:
I deleted my service as per last post, installed a fresh copy of MySQL, and under services made sure I only have 1 MySQL instance.  Finally, I restored all my DBs...

After I went through example and got to see the changed value.  

One thing though during this walk through - Before shutdown, I logged in to mysql password and SHOW DATABASES; gave me the expected results, after shutdown, my root password wasn't accepted, and as a hunch I tried a blank password that was it.  SHOW ATABASES this time only returned the system dbs, not mine, but in this case I was able to see the changed value.

Finally, trying to make this permanent, I changed my.ini to the following, but the valu remains at 1024.

# For advice on how to change settings please see
# http://dev.mysql.com/doc/refman/5.6/en/server-configuration-defaults.html
# *** DO NOT EDIT THIS FILE. It's a template which will be copied to the
# *** default location during install, and will be replaced if you
# *** upgrade to a newer version of MySQL.

[mysqld]
set global group_concat_max_len=4294967295
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at 70% of total RAM for dedicated server, else 10%.
# innodb_buffer_pool_size = 128M

# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin

# These are commonly set, remove the # and set as required.
# basedir = .....
# datadir = .....
# port = .....
# server_id = .....


# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M 

sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES 

Open in new window

0
Steve BinkCommented:
[mysqld]
set global group_concat_max_len=4294967295

Open in new window

Remove "set global " from the beginning of that line and restart the service.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
APD TorontoAuthor Commented:
Thank you for all your help and not giving up...
0
Steve BinkCommented:
No worries..  glad you got it working.  Good luck!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
MySQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.