GP Dynamics processing batch failed to complete posting

Hello All,

When any of my GP 2013 users try to post a particular batch it fails with the following error:
"Batch RMPMXFR username failed to complete posting. Use the Batch Recovery window to complete the posting process"
I notice that the batch status shows as "Posting Interrupted"

I have found out what I believe is the solution, directly from MIcrosoft in the following URL: https://support.microsoft.com/en-us/kb/923381

The resolution looks pretty straight forward but I am concerned about deleting the tables that are specified on the instructions (ACTIVITY, SY00800, SY00801, DEX_LOCK, DEX_SESSION).

My question is, will these tables recreate themselves automatically after applying the solution?

Any help will be appreciated!
LuiLui77Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Steve EndowMicrosoft MVP - Dynamics GPCommented:
Hi,

The Delete SQL statements in that KB article will only remove records from those tables--it will not delete the tables themselves. (I prefer the syntax "DELETE FROM tablename" to avoid that confusion, but many people use the DELETE tablename syntax)

If you run those scripts, the important step is to make sure everyone is logged out of GP and that GP is closed.

And before you try the steps in the KB article, have you tried to access the batch from the GP Batch Recovery window first?  

Thanks,

Steve Endow
Microsoft MVP - Dynamics GP
Dynamics GP Certified IT Professional
LuiLui77Author Commented:
Hi Steve, thanks for your post. Yes we have tried to access the batch via the GP Batch Recovery and no luck.
Victoria YudinOwner / Dynamics GP ConsultantCommented:
In my experience when the RMPMXFR batch fails to post it needs to be fixed directly in the database. There are a number of different variations to the fix, so it is best to have either your Dynamics GP partner or Microsoft Support work with you on this so they can look at your data and determine the appropriate fix for your specific situation.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LuiLui77Author Commented:
Thank you Steve and Victoria for your posts!

In terms of the query syntax, Steve was right but we ended up on asking help to our GP support contractors. It resulted that a record was corrupted and they ended up on resolving the issue in a total different way, so that was a good call Victoria.

Thanks again.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Dynamics

From novice to tech pro — start learning today.