Avatar of gerlis
gerlis
 asked on

Server 2008 SBS Folder/file permissions problem?

Our client running Server SBS 2008, one of the users has reported:

"-    I have a folder on my desktop which only has a shortcut to a website in it.
-    I cannot delete this shortcut or the parent folder, even if I try via \\srv\D$\Users\FolderRedirections\CBrown\Desktop


It says in the Security tab for the shortcut:
You do not have permission to view or edit this object’s permission settings.
so I cannot change the settings.

I even tried logging into the server as both me and your account and trying to delete it there but with no luck.

The folder I would like deleting is:
\\srv\D$\Users\FolderRedirections\CBrown\Desktop\TEMP
with only one file in it called
Outlook via Gmail.url
It is the file that has the permission issues, which stop the folder from being deleted.

I also cannot move or copy the file in any way."

___

I've also had a look on their server and I (even as admin) cannot do anything with this folder.

Any ideas?
Windows Server 2008

Avatar of undefined
Last Comment
gerlis

8/22/2022 - Mon
Larry Struckmeyer MVP

You may have tried already but from both the folder and the one above the problematic one:  try "attrib"  see if it is read only.  remove any attributes with attrib folder/file name -s -h -r

Take ownership with right click-security-advanced

Verify there are no other folders below that make the string exceed the 255 character limit.
Tony Giangreco

The NTFS file security is probably being enforced by ownership of the folder and file as mentioned by Larry.

You need to login as the domain administrator, open an Elevated Command Prompt, edit the following command with the proper path and execute the commands:

takeown /F D:\Users\FolderRedirections\CBrown\Desktop\TEMP\Outlook via Gmail.url
takeown /f D:\Users\FolderRedirections\CBrown\Desktop\TEMP\Outlook via Gmail.url /r /d y

If you have embedded spaces in the file name, you probably need to enclose the path and file name in double quotes.

Here is a link on the solution:
http://windowsitpro.com/windows-vista/taking-ownership-file-or-folder-command-line

Hope this helps!
gerlis

ASKER
Thanks both.

Larry:  It is indeed Read only. I have tried (from an elevated command  prompt):

D:\Users\FolderRedirections\CBrown>attrib desktop -s -h -r

Came back with:

Access denied - D:\Users\FolderRedirections\CBrown\Desktop

Will try TG-TIS's suggestion  later
All of life is about relationships, and EE has made a viirtual community a real community. It lifts everyone's boat
William Peck
Lionel MM

if the above does not work you can try this; create a blank directory, let say c:\empty then run robocopy like this
robocopy c:\empty \\srv\D$\Users\FolderRedirections\CBrown\Desktop\TEMP /mir
that will purge the files in \\srv\D$\Users\FolderRedirections\CBrown\Desktop\TEMP and make it the same as c:\empty with no files in it. if you get an error running robocopy please post it here--thanks and good luck.
ASKER CERTIFIED SOLUTION
gerlis

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
gerlis

ASKER
problem resolved but no idea how/why.