Maximum function nesting level of '100' reached, aborting!

I'm going through a Zend tutorial and when I went to my first page, I got "Fatal error: Maximum function nesting level of 100 reached."

Looking through the internet, I came across a setting that was mentioned repeatedly, that being xdebug. It was recommended that increase the xdebug.max_nesting_leve. But when I look at my ini file, this is what I see:

; XDEBUG Extension

zend_extension = "c:/wamp/bin/php/php5.5.12/zend_ext/php_xdebug-2.2.5-5.5-vc11.dll"
;
[xdebug]
xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir = "c:/wamp/tmp"
xdebug.show_local_vars=0

I don't have that variable. I tried to add it manually so it looked like this:

; XDEBUG Extension

zend_extension = "c:/wamp/bin/php/php5.5.12/zend_ext/php_xdebug-2.2.5-5.5-vc11.dll"
;
[xdebug]
xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir = "c:/wamp/tmp"
xdebug.show_local_vars=0
xdebug.max_nesting_level=250

But that didn't make any difference.

What am I missing?
brucegustPHP DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ray PaseurCommented:
There is probably a loop defining or calling functions inside of functions.  You might want to turn off XDebug completely and see if the fatal error goes away.  Personally I find XDebug to be a big time waster, since it can truncate important things like var_dump() output.  All it really does is change the format of a few pieces of error information.  A better concept to explore is phpunit, where you can get really useful information fast.
0
brucegustPHP DeveloperAuthor Commented:
Morning, Ray! Dang, I'm glad you're up!

Just so I do it right the first time, if my settings are as such:

zend_extension = "c:/wamp/bin/php/php5.5.12/zend_ext/php_xdebug-2.2.5-5.5-vc11.dll"
;
[xdebug]
xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir = "c:/wamp/tmp"
xdebug.show_local_vars=0

It looks like everything is "off," by default. How then do I turn it off?
0
Ray PaseurCommented:
I think this answer gives a good approach.  You probably want to restart everything after making this change, just to be sure.
http://stackoverflow.com/a/8667421/1907917

One of the Stack comments about "recursive functions" seems to make sense.  If XDebug is counting recursions, this could be a false positive for an error.  If the recursions are infinite, XDebug is irrelevant and the PHP memory limit will catch the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
PHP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.