Dell R710 iDRAC6 firmware upgrade keeps failing

Hi Guys,

We run R710s running ESXi 5.1 and they are running in a shared setup. They keep dropping off the network and require a hard reboot.

I have only recently started this role, so I am picking up loads of half finished jobs.

Most have already been upgraded to v1.98 firmware, but one server is currently on 1.80 and just refuses to update to 1.98. I have even tried upgraded to 1.90 firmware as I hought maybe doing it in stages would help but nah. It fails at 30%.

I have tried the web gui multiple rsets and tries and hard reboots. I have compiled my own bootable linux dvd using Dell Repsoitory Manager and it updated everything else but the iDRAC firmware.

I have even used the lifecycle controller repair package and after that I still cant update the iDRAC firmware.

Any body have any ideas on how to proceed?

Also I have been told my numerous people that running in a  shared mode is no good for ESXi hosts, but I cant find nay info?

Cheers,

Bilal
LVL 2
piedthepiperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Seth SimmonsSr. Systems AdministratorCommented:
have you tried OMSA live cd?
boot from that then you can download the firmware and run there
there was an odd issue with the R710 bios updates in linux but ran fine booting from the live cd
the lifecycle controller should update it also though not through the repair package; just boot into it and try updating
if that doesn't work, might look at replacing it (if under warranty) since it seems you've tried everything else

i personally haven't heard of compatibility issues between vmware and running the idrac shared
i always had it dedicated; always lost the connection on reboot if i'm doing a remote console
piedthepiperAuthor Commented:
I have tried the OMSA live cd and it tried to update the iDRAC firmware but it said:

Failed to update to the standby image
Seth SimmonsSr. Systems AdministratorCommented:
what about 1.8.5?

http://www.dell.com/support/home/us/en/04/Drivers/DriversDetails?driverId=3VM7N&fileId=3470464258&osCode=WS8R2&productCode=poweredge-r710&categoryId=ES

in theory, it should just go with the latest but i have seen cases where you have to do some incrementals first

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
piedthepiperAuthor Commented:
This worked ....I have to say to my surprise!

I did incremental to 1.85 and then did a direct update to 1.98 and it worked flawlessly!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.