Exchange 2010 Cas Array

Ok so we have the following scenario

Single forest single domain, two sites

site1
Exch01
Exch02

site2
Exch03

Two CAS arrays have been created however when I run a get-clientaccessarray cas1 (site 1) only has one member Exch2! There are in the same site and one is the next IP up

Any ideas how to get Exch01 into the CAS?
LVL 8
StuartTechnical Architect - CloudAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AmitIT ArchitectCommented:
Can you run this command on Exch01.

Test-Servicehealth and post the result.
0
Adam BrownSr Solutions ArchitectCommented:
It should appear automatically, but it may take a while to update, since the Topology Mapper needs to check things. You can try resetting the Exchange Active Directory Topology service on the missing servers to force an update.
0
AmitIT ArchitectCommented:
I doubt, is CAS role is installed on Exch01, That's why I want you to run that command.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

StuartTechnical Architect - CloudAuthor Commented:
Hi yes sorry I didn't mention all servers are multi role,

Ran test-servicehealth and the CAS says required service MSExchangeFBA is not running. I have started this but it won't be related will it?
0
AmitIT ArchitectCommented:
Ok, can you this command on both servers
nltest /dsgetsite
0
StuartTechnical Architect - CloudAuthor Commented:
Both return site 1
0
StuartTechnical Architect - CloudAuthor Commented:
I think I'm going to delete site1 CAS and recreate it
0
Adam BrownSr Solutions ArchitectCommented:
MSExchangeFBA is the Forms Based Authentication service. Did you try restarting the AD Topology Service for Exchange on the missing servers?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
StuartTechnical Architect - CloudAuthor Commented:
Just tried that, both servers now appear in site 1's CAS Array :)

Thank you very much
0
StuartTechnical Architect - CloudAuthor Commented:
Spot on, Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.