Visual Studio Pro 2010 and Install Shield LE DLL problem

I am using visual studio pro 2010 and Install Shield LE ( Limited Edition ).  I have a project that references a 3rd party DLL, lets call it stuff.dll

when I build my solution and install the resulting msi file, I can watch the target directory.  The DLL gets removed at the very end of the install process.

What's worse is if I do a repair install using add/remove programs in windows, the stuff.dll does get put where it belongs.  It only removes the dll on upgrade

I have tried everything I can think of to fix the problem.

I am fairly inexperience in developing install shield solutions so any help would be greatly appreciated.
LVL 1
revo1059Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
You might try putting the DLL in another directory, like Windows\System32, or CommonFiles.

However, I'm a bit confused, however. Does the file disappear when you initially install your product, or does is disappear during an upgrade? You seem to mention both, so I'm not entirely sure which scenario you're referring to.
revo1059Author Commented:
The file was disappearing during the Upgrade( which was really the uninstall of the old version and install of the new version )

The the dll would reappear during the install of the new version and at the last second before the install shield would say "Finish" it would be removed.

In the end, I was able to solve the issue.  In the install shield project under "upgrade paths" there is a button labeled "Resequence RemoveExistingProducts".

It has something do with Global Assembly Cache.

After I did this, I rebuilt the installer and the dll remained after the install completed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
revo1059Author Commented:
I solved myself.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic.NET

From novice to tech pro — start learning today.