Lexar Jump drive hidden files?

I have been using a Lexar 8GB jump drive for some time.  However, I now note that the free space is very much less that the total less the visible files. The MS-DOS (FAT32) Get Info shows Capacity of 7.86 GB and Available of 1.38GB (see attached screen shot).  The Finder display for the Jump Drive shows only a relatively small total (see attached screen shot).  If there is a hidden file system, where does one find it, and what does one have to do to delete the contents (assuming that the contents are not fulling some vital function)?
I need to use this Jump Drive for the READYBOOST function on my Windows 7 system under Boot Camp for my MacBook Pro mid-2012 laptop under OS 10.9.5 (Maverick).
Appreciatively, Arbyem
Lexar-USB-Info-8GB--2015-08-06-Info--at-
Lexar-USB-File-Contents-2015-08-06-at-3.
R_Bruce_MorrisColonel (Retired)Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Scott CSenior EngineerCommented:
Those numbers are right.  6.48 + 1.38 = 7.86.  

Like all storage devices, you aren't ever going to get the "full" gig.  Any compact flash, USB drive or HD all have this same "loss".
0
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi ScottCha: Thanks for the prompt response.  However, my problem is not with this reality of not getting the "full" capacity.  Rather it is with the huge disparity between the Capacity less the goal of used capacity formed by the listed folders/files in Finder, and the 6.48 used capacity displayed.  Some unlisted folder(s)/file(s) clearly must be consuming this huge unaccounted for capacity.  Any possibility of "hidden folder/file" aspects?
Arbyem
0
strungCommented:
Scott, it doesn't look to me from the second screen shot that 6.48 gigs have been used.

Bruce, there may be some invisible files on the disk. This free utility:  http://invisiblix.read-write.fr will let you view invisible files.

Before you do that, though, with the Lexar plugged in, try emptying the trash. The Trash won't show up in the file count, but the space won't be released until the trash is emptied.
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

Scott CSenior EngineerCommented:
Ok.  I see what you are getting at.  Should have looked at the second screen more closely.

You could always try booting with a live distro of Knoppix and looking at the drive.

That should show you any and all files.

http://www.knopper.net/knoppix/index-en.html
0
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi strung: Thanks for your prompt informative response.  I do not see any option to empty trash from a USB drive.
I have not yet tried your suggested free utility, but I will certainly do so.
Appreciatively, Arbyem
0
strungCommented:
To empty the trash, with the Lexar plugged in, click on the desktop to make sure you are in Finder, the pull down the Finder Menu to Empty Trash. This will empty the trash on both the Lexar and the internal HD at the same time.
0
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi again strung and ScottCha: I have now tried both the "empty trash" and invicibliX.app suggestions.  The empty trash step only reduced the avail;able storage marginally (I now have 1.55 GB available).  As for the invisiliX.app function, I can only get part of the icon displayed on my screen relative to that shown on the relevant website.  What action is supposed to be taken to operate the application once opened?
For ScottCha, I am reluctant to delve into the knoppix application approach, because I do not have the appropriate knowledge to take that approach.
Any other possible approaches to a resolution?
Appreciatively,
Bruce
0
strungCommented:
If you installed it correctly, you should have a copy of the InvisibliX app in either your /Applications folder or your /Applications/Utilities folder. Double-click on the App to launch it. Then go to the File menu and pull it down to Show Hidden Files in Finder. Then browse to the Lexar volume using Finder.

Take a screen shot and post it here.

Then go back to the InvisibliX app and pull down the File menu to Hide Invisible Files in Finder to restore the normal function.
0
strungCommented:
If you want a simpler solution. Just copy everything off the drive to a folder on your hard drive. Then use Disk Utility to erase and reformat the Lexar drive. Make sure you format it as FAT32.

Once that is done, copy everything back onto the Lexar Drive.
0
strungCommented:
If you want  simpler solution, just copy everything off the Lexar into a folder on your hard drive.

Then use Disk Utility to erase and reformat the Lexar. Make sure you format it as FAT32.

Then copy everything you want back onto the Lexar.
0
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi  strung: I executed your process to re-employ the invisiblx.app.  I still get only part of the icon displayed on my desktop. The resulting screen shot for the Lexar USB from Finder is attached.
I also attempted your simple process to copy the contents of the Lexar USB to a desktop folder "lexarcopy", erasing the USB jump drive using the Mac Disk Utility, then copying the contents (6.31GB) back onto the erased Lexar USB. The copying process displayed ".fseventsd cannot be copied", then proceeded to produce only the invisible files when the process was apparently completed.  That screen shot is also attached.  I do not understand why the remaining files from the temporary folder do not appear to have been copy as part of the "paste items" step.
What can be done next?
Lexar-Screen-Shot-2015-08-07-at-10.53.38
Lexar-Screen-Shot-after-copyback-from-fo
0
strungCommented:
Toggle the InvisibliX application to hide the invisible files. I presume you have the visible files still safely on your hard drive.
Reformat the Lexus again and this time copy back only the visible files.
0
R_Bruce_MorrisColonel (Retired)Author Commented:
Hi strung: Thanks. I performed your process in your last post. I now have 4.66 GB free space (see attached screen shot). Hopefully, the READYBOOST will function correctly for my Windows 7 under Boot Camp.
I will close this post and award points, unless you have any further comments before I do so.
Appreciatively, Arbyem
LexarContents-08Aug2015.png
0
strungCommented:
Glad it worked. From the screenshots you posted, the missing 3 GB was in the invisible FOUND.000 file.  This file was created as a result of disk directory corruption on your jump drive. Reformatting the drive would have fixed this.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
R_Bruce_MorrisColonel (Retired)Author Commented:
Thanks for everything.  Obviously, reformatting did resolve the problem. The corruption could have occurred anytime during my use of the Lexar during my Mac OS 10.9.5 Maverick (I have not yet upgraded to Yoseminite) sessions. I usually eject the Lexar and only use it for my Windows 7 Boot Camp sessions; but often I forget to do so.  I use the Lexar for separate backups for my Windows 7 2007 Quicken XG application.  When it is connected for Mac sessions, I notice the activity red light indicator flashing rather more often that I consider "normal".
Appreciatively, Arbyem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.