DNS setting keeps changing by itself from obtains to use

I have a windows 7 computer 64bit. Whenever I set the DSN for my adapter to "Obtain DNS server address automatically" my connection to the internet works fine. But when I restart the machine, it changes to "Use the following..." by itself. I have a home network using a Zyxel modem/router from centurylink.
rsavoy1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

footechCommented:
When did this start happening?  What is the DNS set to?
Sounds like you have a program that is changing this setting on every reboot.  I'd use Sysinternals Autoruns to check out all the programs that are starting automatically and make sure you recognize them.  Malware could also be the culprit - try running RogueKiller first off.
Scott ThomsonCommented:
Agree with above.. Is this a work pc? it could also ge group policy of some sort.
AMU1962Commented:
I agree sounds like malware.

combofix  works well and is my first port of call when malware is suspected.

If this is clear then set them manually to 8.8.8.8 and 8.8.4.4 which belong to google.
Cloud as a Security Delivery Platform for MSSPs

Every Managed Security Service Provider (MSSP) needs a platform to deliver effective and efficient security-as-a-service to their customers. Scale, elasticity and profitability are a few of the many features that a Cloud platform offers. View our on-demand webinar to learn more!

rsavoy1Author Commented:
Thank you all for your responses. I will run RogueKiller and see if that helps. (Tried Windows Defender but that didn't help.)

To answer the questions posed:
1.      This is a home computer on a home network of 2 computers and a couple of phones.
2.      This computer is windows 7 and is connected wirelessly to the router in the room below.
3.      The problem started happening 2 weeks ago when this computer’s USB NIC stopped working. I was unable to get it working and bought a new NIC (on the 3rd new one now). It worked when installed but when the computer was restarted, it stopped working- but at the time we didn’t know why.  Re-installing fixed it but same the thing happened when we restarted the machine.  Spent 3 hours last weekend with Linksys tech support and finally saw the problem.
4.      I tried resetting manually assigned to the ones the router was using when it assigned them dynamically but the same thing happened won re-boot.
5.      The numbers being set are 8.38.77.107 and 5.75.84.141
rsavoy1Author Commented:
From what RogueKiller is reporting, it looks like my ws2_32.dll and ntdll.dll files may be infected. Detection: IAT:Inl (Hook.IEAT). Any recommendations on how to proceed?
rsavoy1Author Commented:
I ran combofix   . Attached is the report.
ComboFix.txt
rsavoy1Author Commented:
Combofix did remove one file, but I just re-booted the machine and the problem is still there.
footechCommented:
Here's my opinion on Combofix:  although I think it's a good program, it's not really designed for the layperson, and as such doing anything with it beyond the automatic fixes it does should only be done with the instruction of someone trained to use it (its guide says as much).  I've also observed that it makes a change to the way that short file names are generated (not sure for the rationale behind that), and that change broke an application's functionality.

Here's what I would suggest (don't reboot between any of the steps):
- run RogueKiller or rkill (should stop any processes that might interfere with/hide from later steps)
- run TDSKiller
- run MalwareBytes (just use the free functionality)
- set your NIC settings back, then reboot and see if they've changed.
rsavoy1Author Commented:
Thanks footech. I did these steps and the problem is still there. I pulled the reports from RogueKiller  for you to look at if you have time.
RougeKiller-Antirootkit-rpt.txt
RougeKiller-drive-rpt.txt
RougeKiller-Registry-rpt.txt
footechCommented:
All the files are the same.  :)

Except for "Anti-phishing Domain Advisor" and "AVG SafeGuard toolbar" I think all the registry entries should be removed.

Check in your installed programs (in Control Panel) whether there's anything installed around the time that this began to happen.  Might see if there's an entry for Speedly and remove it.  Often you'll see things bundled together that have the same install date, and when they're Potentially Unwanted Proprams you may be able to uninstall them (or most of them) normally before removing bits and pieces of them with anti-malware software.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
footechCommented:
I can't be certain if the items detected under anti-rootkit are malicious, but I would go ahead and clean those too.

Remember, RogueKiller is only the first step before running MalwareBytes.
rsavoy1Author Commented:
TDSKiller and MalwareBytes  didn't find anything. butI'll run them again once i make these changes.
rsavoy1Author Commented:
Thanks footech. I removed the registry entries as you suggested. I also ran DLL Files fixer which did a lot of registry cleanup.  Between the two, the problem is fixed. Thank you so much for your help!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.