SQL Server 2014 firewall setting

After windows 10 upgrade, I am not able to connect to SQL Server.

Question: Could you please help me to make sure the fire wall 1) turned on and 2) it has correct settings?

I am reading: "... If a firewall is turned on but not correctly configured, attempts to connect to SQL Server might be blocked."

From: https://technet.microsoft.com/en-us/library/ms175043(v=sql.120).aspx 
"As an alternative to configuring SQL Server to listen on a fixed port and opening the port, you can list the SQL Server executable (Sqlservr.exe) as an exception to the blocked programs. Use this method when you want to continue to use dynamic ports. Only one instance of SQL Server can be accessed in this way."

We can apply easiest method which helps connect to database engine because this database is for practice purpose and doesn't contain any critical data.
LVL 34
Mike EghtebasDatabase and Application DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Why are you thinking the issue is with the firewall? This is not a local issue?
0
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
In my laptop, I had Windows 7 and SQL Server 2014 working just fine. But, after Windows 10 upgrade I am having connecting to database engine. At this point I am focusing on the firewall issue to make sure:

1. It is turned on.
2. It has correct setting (any setting to allow database engine to connect).

for background infor see: http://www.experts-exchange.com/questions/28703140/SQL-Server-Login-After-Windows-10-upgrade.html
0
Éric MoreauSenior .Net ConsultantCommented:
I had a similar issue yesterday. I had "Network Library = dbmssocn" in my connection string. I removed it and it is now working properly. Do you have this setting too?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Like I said, it's a local connection so shouldn't be an issue with FW.
Can you connect via DAC? Which .NET framework is installed? Did you check the logs in Event Viewer for any error entry?
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
Did you install SQL Server 2014 SP1 before upgrading to Windows 10?
Microsoft recommends that as minimum requirement: https://support.microsoft.com/en-us/kb/2681562
0
Éric MoreauSenior .Net ConsultantCommented:
Just installed SP1 and I can now connect even if I specify the network protocol. Strange!
0
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
@Eric,

re:> I had a similar issue yesterday. I had "Network Library = dbmssocn" in my connection string. I removed it and it is now working properly. Do you have this setting too?

I am double clicking on SSMS icon, it prompts me with login screen with the default login shown below. When I click on connect, I get:login
@Vitor,

I have been using SQL Server with Windows 7 for at least 6 months. After Windows 10 upgrade I am having this problem.

As stated above, I need step by step instructions to determine:

1. Is Firewall is turned on.
2. Does the Firewall have correct setting (any setting to allow database engine to connect).
0
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
I got it working. The problem seemed to be some of the server was set to automatic (and disabled) but I changed them to running and Manual.

I hope it stays running.

Mike
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mike EghtebasDatabase and Application DeveloperAuthor Commented:
I got it working. The problem seemed to be some of the server was set to automatic (and disabled) but I changed them to running and Manual.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.