CISCO RV32x SSH connection problem

I have a CISCO RV320 VPN router.
I connect through SSH on the device but when I get prompted for my credentials I enter my username and password to login. Then authentication fails.
I only have one account on the RV320 and is the one that I use to connect to the GUI which I do successfully. That user is the system administrator.
the firewall is disabled and SSH is enabled on the device.

I tried to create other users but unfortunately it does not work.
Christoforos AcadjiotisSystems and Network AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Dan CraciunIT ConsultantCommented:
According to this document, if SSH is enabled you should be able to login to CLI using a SSH2 client and authenticating with the same user and password as the GUI.

If not, then you should file a bug report, as this is the expected behavior.

HTH,
Dan
0
Christoforos AcadjiotisSystems and Network AdministratorAuthor Commented:
Hi Dan and thanks for the speed! :)

I do establish a connection with SSH v2. Authentication fails though. The credentials are correct for sure as I use them to log in the web gui.
the username I use is an Administrator. only one such account can be created on the RV320.
0
JustInCaseCommented:
If you can't create other user from GUI maybe your account don't have level 15 privilege.
You can always reset device to factory defaults in case that everything other else fails.
Keep reset button in hole on front of device longer than 10 seconds - and device  will be reset to  factory default configuration (if you can save your current configuration from GUI before you do so).
Manual
The password cannot be recovered if it is lost or forgotten. If the password is lost or forgotten, the device must be reset to the factory default settings, removing all configuration changes. If you are accessing the device remotely and reset the device to factory defaults, you cannot log into the device until you have established a local, wired link on the same subnetwork.
If you did try to restart device and still you can't get access to device I guess that you will have to reset to default config at some point in time...
For SSH -  did you set your client software to use SSH v2 since it is only supported on device.
CLI guide
0
Dan CraciunIT ConsultantCommented:
Backup your config, restore to factory settings, enable SSH then login using defaults (cisco/cisco or whatever is the default on that model).

If it does work, then the problem is in your configuration.

If it still does not work in an out-of-the-box config, then the problem is the router.
1

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Christoforos AcadjiotisSystems and Network AdministratorAuthor Commented:
I would do that... but the device is at a remote location that I have limited physical access to.

Sounds like a plan though. I'll give that a go when the opportunity appears.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.