Windows 10 - Permission Troubles after upgrading from Windows 7

I recently installed Windows 10 Professional version, and I'm having issues with permissions after doing so.

I initially installed with my Microsoft Account, which seemed to cause quite a few issues (slow loading, Outlook troubles, etc). I switched to using my original local account, and now I am get constant "Access denied" error messages when trying to save documents to the My Documents folder (and other places). The user I'm logging in with is a member of the Administrators group, so I should have permissions to save files pretty much anywhere, and certainly in My Documents

I've found that giving the HomeUsers group Full Control permission to a folder resolves this - but I shouldn't have to do that, since my login is a member of the Administrators group.

I realize I can just go down the list and reset all the permissions for every folder, but I'm curious why this happened, and also why my Administrator-level permissions don't allow me access to those files and folders?
LVL 86
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
Never logon with an admin account, but rather only use a standard account, and when anything needs admin rights UAC will as you for your admin account's credentials. The Admin accounts should only ever be used for admin tasks, and nothing else.

Besides that, "My Documents" isn't and actual folder, but rather just a directory junction that points to the "Documents" folder of your user account. It is only present for some backward compatibility With ancient software. You should rather just save your data directly to the Documents Folder, or to the Public folder, as from there you have access to your files from every Account.
JustInCaseCommented:
Most likely answer is that you were (your account) owner of those files, and that something go wrong on relation SID - Account itself. I think you don't have to add User account to folder, you can add your account to those folders and it should be fine.
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareAuthor Commented:
Thanks Rindi. I appreciate your insight, but I'm not sure how that helps with my issue.

With my current setup, I don't understand why I cannot save to the Documents folder. The ONLY way I can save is if I give Full Control to the "HomeUsers" group. By my understanding of permissions (limited as it is), a user who is part of the Admins group should be able to save documents anywhere.

I do understand that "My Documents" is a virtual folder, and I understand where the actual files are stored (under Users - <name> - Documents). When I set permissions on those folders, I do so in that location.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

JustInCaseCommented:
Give just your account full permissions (not HomeUsers group) and include Admin group...
I made few times mistake to remove administrators (on my computer) to some folder and enable just my user account access to that folder, and of course... after reinstall I could not do anything... I had to restore OS from backup to take ownership.
David Johnson, CD, MVPOwnerCommented:
What has happened is the SID has changed.Windows X command prompt (admin)
if you haven't changed the location of your user files
takeown /f c:\users\yourusername /r /d n
from explorer right click on documents select security and give yourself full permissions and delete the 5-1-x-x-x-x entry, repeat for your other user folders (music, videos, pictures etc)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareAuthor Commented:
Thanks everyone. I'm implementing the takeown suggestion today and will post back with results early next week.

Regarding deleting the user:

When I click the Security tab, my system shows a value like S1-5-21-2053xxxxxx initially, and then that changes to:

Home Users (SCOTTS64\HomeUsers)

Are you suggesting I remove that listing from my Group or User names section?
David Johnson, CD, MVPOwnerCommented:
Homeusers is your homegroup user group.
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareAuthor Commented:
Takeown seems to work, but I'm still concerned as to why I had to resort to that. might be time to rebuild (plus I can convince myself that I MUST have SSDs for my OS discs).
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareAuthor Commented:
thanks for your help.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.